summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2023-07-08 08:20:05 -0500
committerBen Kohler <bkohler@gentoo.org>2023-07-08 13:41:40 -0500
commit1268f86bc7761300f347db0612f2fa33190243b2 (patch)
treee1a578dec9e96fb25c2f0be703c7b82da99d18cb /app-text/grip
parentdev-python/keyutils: update EAPI 7 -> 8, use PEP517 build (diff)
downloadgentoo-1268f86bc7761300f347db0612f2fa33190243b2.tar.gz
gentoo-1268f86bc7761300f347db0612f2fa33190243b2.tar.bz2
gentoo-1268f86bc7761300f347db0612f2fa33190243b2.zip
app-text/grip: update EAPI 7 -> 8, use PEP517 build
Closes: https://bugs.gentoo.org/909898 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'app-text/grip')
-rw-r--r--app-text/grip/grip-4.6.1-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-text/grip/grip-4.6.1-r1.ebuild b/app-text/grip/grip-4.6.1-r1.ebuild
new file mode 100644
index 000000000000..0e207a8554e7
--- /dev/null
+++ b/app-text/grip/grip-4.6.1-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi
+
+DESCRIPTION="Preview GitHub Markdown files like Readme locally before committing them"
+HOMEPAGE="https://github.com/joeyespo/grip"
+LICENSE="MIT"
+
+SLOT="0"
+
+KEYWORDS="~amd64"
+
+RDEPEND="
+ !media-sound/grip
+ >=dev-python/docopt-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/flask-0.10.1[${PYTHON_USEDEP}]
+ >=dev-python/markdown-2.5.1[${PYTHON_USEDEP}]
+ >=dev-python/path-and-address-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pygments-1.6[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.4.1[${PYTHON_USEDEP}]
+"