summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/iso-codes
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/iso-codes')
-rw-r--r--app-text/iso-codes/Manifest2
-rw-r--r--app-text/iso-codes/iso-codes-3.57.ebuild69
-rw-r--r--app-text/iso-codes/iso-codes-3.59.ebuild69
-rw-r--r--app-text/iso-codes/metadata.xml11
4 files changed, 151 insertions, 0 deletions
diff --git a/app-text/iso-codes/Manifest b/app-text/iso-codes/Manifest
new file mode 100644
index 000000000000..0735bbf381e9
--- /dev/null
+++ b/app-text/iso-codes/Manifest
@@ -0,0 +1,2 @@
+DIST iso-codes-3.57.tar.xz 3773756 SHA256 dd6acd92843b69530fce535d3d6fd947ddb3802f0d5fc1bd214d1cb7d2bf5c47 SHA512 a58e48be152960d2391123e88b48f1c43e0bf0ac880a8d6a3ec7c8154e67fd40f264063cdf7106da9d261a5fb82f64d67545a17f69ec81141f10d1eb2d897424 WHIRLPOOL 9b6de080edc6c54071a8b7584de90af3554f91d77973dceb856570b2c1760ad89a807112903cd24697bab672024d319b72ce3141fdd0dc15405bf54bbd9b53ce
+DIST iso-codes-3.59.tar.xz 3771916 SHA256 63d5ef035a96223f1fc8f36b711082f806e1666852dfc4149eeca8fd435d76ed SHA512 e1ac1c4717fd5a9daf76df109dadb24daa7dbf54b09736409e4cf4162de84038ab81ad03afecd3423d288bba306bf27f1301c03912c70a258a763a72fe8a77b4 WHIRLPOOL d56e8e81c1d6668c34d83035174aad2d393f2643ed8a4ef52f379119bb0d3a214ad9bd62d4087bfde8e3e60e427b1572eb41521dd02f081bd013278b3218bbd2
diff --git a/app-text/iso-codes/iso-codes-3.57.ebuild b/app-text/iso-codes/iso-codes-3.57.ebuild
new file mode 100644
index 000000000000..5c8b9c4a1b30
--- /dev/null
+++ b/app-text/iso-codes/iso-codes-3.57.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PLOCALES="af am ar as ast az be bg bn bn_IN br bs byn ca crh cs cy da de dz el en eo es et eu fa fi fo fr ga gez gl gu haw he hi hr hu hy ia id is it ja ka kk km kn ko kok ku lt lv mi mk ml mn mr ms mt nb ne nl nn nso oc or pa pl ps pt pt_BR ro ru rw si sk sl so sq sr sr@latin sv sw ta te th ti tig tk tl tr tt tt@iqtelif ug uk ve vi wa wal wo xh zh_CN zh_HK zh_TW zu"
+
+inherit eutils l10n
+
+DESCRIPTION="ISO language, territory, currency, script codes and their translations"
+HOMEPAGE="http://pkg-isocodes.alioth.debian.org/"
+SRC_URI="http://pkg-isocodes.alioth.debian.org/downloads/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+RDEPEND=""
+DEPEND="
+ app-arch/xz-utils
+ sys-devel/gettext
+"
+
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip"
+
+src_prepare() {
+ local norm loc all_locales mylinguas
+ local all_norms="iso_15924 iso_3166 iso_3166_2 iso_4217 iso_639 iso_639_3 iso_639_5"
+
+ # l10n_find_plocales_changes doesn't support multiple directories
+ einfo "Looking for new locales ..."
+ for norm in ${all_norms}; do
+ pushd "${norm}" > /dev/null || die
+ for loc in *.po; do
+ all_locales+="${loc%.po} "
+ done
+ popd > /dev/null
+ done
+
+ all_locales=$(echo "${all_locales}" | sed 's/ /\n/g' | sort | uniq)
+ all_locales=${all_locales//[[:space:]]/ }
+ all_locales=${all_locales#[[:space:]]}
+ all_locales=${all_locales%[[:space:]]}
+ if [[ ${PLOCALES} != ${all_locales} ]]; then
+ einfo "There are changes in locales! This ebuild should be updated to:"
+ einfo "PLOCALES=\"${all_locales}\""
+ else
+ einfo "Done"
+ fi
+
+ for norm in ${all_norms}; do
+ einfo "Preparing ${norm} ..."
+ pushd "${norm}" > /dev/null || die
+ mylinguas=
+ for loc in *.po; do
+ if use "linguas_"${loc%.po}; then
+ mylinguas+="${loc} "
+ fi
+ done
+
+ sed -e "s:pofiles =.*:pofiles = ${mylinguas} ${NULL}:" \
+ -e "s:mofiles =.*:mofiles = ${mylinguas//.po/.mo} ${NULL}:" \
+ -i Makefile.am Makefile.in || die "sed in ${norm} folder failed"
+ popd > /dev/null
+ done
+}
diff --git a/app-text/iso-codes/iso-codes-3.59.ebuild b/app-text/iso-codes/iso-codes-3.59.ebuild
new file mode 100644
index 000000000000..d5169d2e9133
--- /dev/null
+++ b/app-text/iso-codes/iso-codes-3.59.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PLOCALES="af am ar as ast az be bg bn bn_IN br bs byn ca crh cs cy da de dz el en eo es et eu fa fi fo fr ga gez gl gu haw he hi hr hu hy ia id is it ja ka kk km kn ko kok ku lt lv mi mk ml mn mr ms mt nb ne nl nn nso oc or pa pl ps pt pt_BR ro ru rw si sk sl so sq sr sr@latin sv sw ta te th ti tig tk tl tr tt tt@iqtelif ug uk ve vi wa wal wo xh zh_CN zh_HK zh_TW zu"
+
+inherit eutils l10n
+
+DESCRIPTION="ISO language, territory, currency, script codes and their translations"
+HOMEPAGE="http://pkg-isocodes.alioth.debian.org/"
+SRC_URI="http://pkg-isocodes.alioth.debian.org/downloads/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+RDEPEND=""
+DEPEND="
+ app-arch/xz-utils
+ sys-devel/gettext
+"
+
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip"
+
+src_prepare() {
+ local norm loc all_locales mylinguas
+ local all_norms="iso_15924 iso_3166 iso_3166_2 iso_4217 iso_639 iso_639_3 iso_639_5"
+
+ # l10n_find_plocales_changes doesn't support multiple directories
+ einfo "Looking for new locales ..."
+ for norm in ${all_norms}; do
+ pushd "${norm}" > /dev/null || die
+ for loc in *.po; do
+ all_locales+="${loc%.po} "
+ done
+ popd > /dev/null
+ done
+
+ all_locales=$(echo "${all_locales}" | sed 's/ /\n/g' | sort | uniq)
+ all_locales=${all_locales//[[:space:]]/ }
+ all_locales=${all_locales#[[:space:]]}
+ all_locales=${all_locales%[[:space:]]}
+ if [[ ${PLOCALES} != ${all_locales} ]]; then
+ einfo "There are changes in locales! This ebuild should be updated to:"
+ einfo "PLOCALES=\"${all_locales}\""
+ else
+ einfo "Done"
+ fi
+
+ for norm in ${all_norms}; do
+ einfo "Preparing ${norm} ..."
+ pushd "${norm}" > /dev/null || die
+ mylinguas=
+ for loc in *.po; do
+ if use "linguas_"${loc%.po}; then
+ mylinguas+="${loc} "
+ fi
+ done
+
+ sed -e "s:pofiles =.*:pofiles = ${mylinguas} ${NULL}:" \
+ -e "s:mofiles =.*:mofiles = ${mylinguas//.po/.mo} ${NULL}:" \
+ -i Makefile.am Makefile.in || die "sed in ${norm} folder failed"
+ popd > /dev/null
+ done
+}
diff --git a/app-text/iso-codes/metadata.xml b/app-text/iso-codes/metadata.xml
new file mode 100644
index 000000000000..464d8fa1123a
--- /dev/null
+++ b/app-text/iso-codes/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome</herd>
+ <longdescription lang="en">
+ This package provides the ISO-639 Language code list, the ISO-3166
+ Territory code list, and ISO-3166-2 sub-territory lists, and all their
+ translations in gettext .po form.
+ </longdescription>
+</pkgmetadata>
+