summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-12-29 23:13:32 +0100
committerManuel Rüger <mrueg@gentoo.org>2015-12-29 23:13:32 +0100
commit75379df2e54ae626b03169819990e40e573c08f4 (patch)
tree4ba814ee04bb306662e3eaf6ff444060e47ec1ad /app-text/libwpg/libwpg-0.3.1.ebuild
parentx11-libs/libdrm: Remove old (diff)
downloadgentoo-75379df2e54ae626b03169819990e40e573c08f4.tar.gz
gentoo-75379df2e54ae626b03169819990e40e573c08f4.tar.bz2
gentoo-75379df2e54ae626b03169819990e40e573c08f4.zip
app-text/libwpg: Version bump
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-text/libwpg/libwpg-0.3.1.ebuild')
-rw-r--r--app-text/libwpg/libwpg-0.3.1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-text/libwpg/libwpg-0.3.1.ebuild b/app-text/libwpg/libwpg-0.3.1.ebuild
new file mode 100644
index 000000000000..a336154985a3
--- /dev/null
+++ b/app-text/libwpg/libwpg-0.3.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit alternatives eutils
+
+DESCRIPTION="C++ library to read and parse graphics in WPG"
+HOMEPAGE="http://libwpg.sourceforge.net/libwpg.htm"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="|| ( LGPL-2.1 MPL-2.0 )"
+SLOT="0.3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~x86"
+IUSE="doc static-libs"
+
+RDEPEND="
+ app-text/libwpd:0.10[tools]
+ dev-libs/librevenge
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_configure() {
+ econf \
+ --disable-werror \
+ --program-suffix=-${SLOT} \
+ --docdir="${EPREFIX%/}/usr/share/doc/${PF}" \
+ $(use_with doc docs) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
+
+pkg_postinst() {
+ alternatives_auto_makesym /usr/bin/wpg2svgbatch.pl "/usr/bin/wpg2svgbatch.pl-[0-9].[0-9]"
+ alternatives_auto_makesym /usr/bin/wpg2svg "/usr/bin/wpg2svg-[0-9].[0-9]"
+ alternatives_auto_makesym /usr/bin/wpg2raw "/usr/bin/wpg2raw-[0-9].[0-9]"
+}
+
+pkg_postrm() {
+ alternatives_auto_makesym /usr/bin/wpg2svgbatch.pl "/usr/bin/wpg2svgbatch.pl-[0-9].[0-9]"
+ alternatives_auto_makesym /usr/bin/wpg2svg "/usr/bin/wpg2svg-[0-9].[0-9]"
+ alternatives_auto_makesym /usr/bin/wpg2raw "/usr/bin/wpg2raw-[0-9].[0-9]"
+}