summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-03-10 18:51:52 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-03-10 18:51:52 +0100
commit49a458ac5e020e9643adf9554e1352bc9809d1e5 (patch)
treeb78e285ee2d3dc1682d635529ad5f3166d2a9f2b /app-text/mandoc/mandoc-1.14.5.ebuild
parentapp-admin/keepassxc: Removed old. (diff)
downloadgentoo-49a458ac5e020e9643adf9554e1352bc9809d1e5.tar.gz
gentoo-49a458ac5e020e9643adf9554e1352bc9809d1e5.tar.bz2
gentoo-49a458ac5e020e9643adf9554e1352bc9809d1e5.zip
app-text/mandoc: Bump to version 1.14.5
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-text/mandoc/mandoc-1.14.5.ebuild')
-rw-r--r--app-text/mandoc/mandoc-1.14.5.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/app-text/mandoc/mandoc-1.14.5.ebuild b/app-text/mandoc/mandoc-1.14.5.ebuild
new file mode 100644
index 000000000000..4b5e8af2d4fa
--- /dev/null
+++ b/app-text/mandoc/mandoc-1.14.5.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit multilib toolchain-funcs
+
+DESCRIPTION="Suite of tools compiling mdoc and man"
+HOMEPAGE="http://mdocml.bsd.lv/"
+SRC_URI="http://mdocml.bsd.lv/snapshots/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static"
+
+LIB_DEPEND="sys-libs/zlib[static-libs(+)]"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
+DEPEND="${RDEPEND}
+ static? ( ${LIB_DEPEND} )"
+
+src_prepare() {
+ default
+
+ # The db-install change is to support parallel installs.
+ sed -i \
+ -e '/ar rs/s:ar:$(AR):' \
+ -e '/^db-install:/s:$: base-install:' \
+ Makefile || die
+
+ cat <<-EOF > "configure.local"
+ PREFIX="${EPREFIX}/usr"
+ BINDIR="${EPREFIX}/usr/bin"
+ SBINDIR="${EPREFIX}/usr/sbin"
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+ MANDIR="${EPREFIX}/usr/share/man"
+ INCLUDEDIR="${EPREFIX}/usr/include/mandoc"
+ EXAMPLEDIR="${EPREFIX}/usr/share/examples/mandoc"
+ MANPATH_DEFAULT="${EPREFIX}/usr/man:${EPREFIX}/usr/share/man:${EPREFIX}/usr/local/man:${EPREFIX}/usr/local/share/man"
+
+ BINM_MAN=mman
+ BINM_SOELIM=msoelim
+ BINM_APROPOS=mapropos
+ BINM_WHATIS=mwhatis
+ BINM_MAKEWHATIS=mmakewhatis
+ MANM_MAN=mandoc_man
+ MANM_MDOC=mandoc_mdoc
+ MANM_ROFF=mandoc_roff
+ MANM_EQN=mandoc_eqn
+ MANM_TBL=mandoc_tbl
+ MANM_MANCONF=mman.conf
+
+ CFLAGS="${CFLAGS} ${CPPFLAGS}"
+ LDFLAGS="${LDFLAGS} $(usex static -static '')"
+ AR="$(tc-getAR)"
+ CC="$(tc-getCC)"
+ # The STATIC variable is only used by man.cgi.
+ STATIC=
+ EOF
+}