summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-08-23 21:40:47 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-08-24 00:14:29 +0200
commite79811e9d2d5fe4227d6a1491ec905293b5d7fa3 (patch)
treea7d016e615437b43222ec6e7ce33beb825fe2c57 /app-text/pandoc-bin
parentsys-apps/gentoo-functions: update LICENSE (diff)
downloadgentoo-e79811e9d2d5fe4227d6a1491ec905293b5d7fa3.tar.gz
gentoo-e79811e9d2d5fe4227d6a1491ec905293b5d7fa3.tar.bz2
gentoo-e79811e9d2d5fe4227d6a1491ec905293b5d7fa3.zip
app-text/pandoc-bin: bump to 3.1.6.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-text/pandoc-bin')
-rw-r--r--app-text/pandoc-bin/Manifest2
-rw-r--r--app-text/pandoc-bin/pandoc-bin-3.1.6.2.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/app-text/pandoc-bin/Manifest b/app-text/pandoc-bin/Manifest
index e70f5d653ee7..235e24eebd59 100644
--- a/app-text/pandoc-bin/Manifest
+++ b/app-text/pandoc-bin/Manifest
@@ -4,3 +4,5 @@ DIST pandoc-3.1.6-linux-amd64.tar.gz 19664028 BLAKE2B be9dc7651001bd4f59639cd6a8
DIST pandoc-3.1.6-linux-arm64.tar.gz 21780669 BLAKE2B a3715890a8139f8631f8c7c7170d10e262f044e70b1383317fab063cf9dba2455090c30913617d93710e0054f0133afbec5980abd36b6c729c6b99bd7375521e SHA512 615a403070aae7722e2b939a940602ce01f37cd00f6621925b59939fe7ceae73031ac23ee94bcb1e6f6ab12a2b570b81cf5baa55808d503677511f238e30f880
DIST pandoc-3.1.6.1-linux-amd64.tar.gz 31085424 BLAKE2B 35cdd4e9671720d9f77133791a197ba85dfcdb137ab7d3d9247eb5dabdc287729059633f43f1f42f6636799f3d7379e6bb8b81b4b2a9773520fff819c363bb88 SHA512 cbfeb7444aaac22fcc75e31c09888da4e67cc20acb1a75e4d24c07ddbcd9ea516cdcf19088c9e4f308e2325a76591e20322a9264ca641a2f80dd7a385d5c8c06
DIST pandoc-3.1.6.1-linux-arm64.tar.gz 33743040 BLAKE2B d6e70616ce8e61e31d2da6aeb6097e464d1b410f9caae8550846ee238a39c3f1fee93d4c18501cdebfc7b3142be9a691fdf2bf15b38b6184ad491df6cee17d22 SHA512 552bfb504d2e03ffbb3e46c67fef8056d073821b141e97b32248d77b569c752a13f69cba4c0e3a4fdf340a14ff3a1b1e2337e8545ac41fcf4f8a76c6e2e10bb7
+DIST pandoc-3.1.6.2-linux-amd64.tar.gz 31164360 BLAKE2B cdd787a2c6b2bac3a9a1a3d6a216e5279d83385a61fd0c61d643744214564f81274dd380402c46ab2938f7bb0a11aabb9a6c99b31b63962c8a2fe043fba41e5c SHA512 b81c708d60cb46a98377af374de0f9b7b5eef38f9cdd8e5490d1072627f34c226e8e2f03f172c4c87e5f2164794cef1b3e39598f86de3e45cb0396ae9416359d
+DIST pandoc-3.1.6.2-linux-arm64.tar.gz 33827200 BLAKE2B 710829bbef6764a3a373a75d29dc39b843de225bf71d25da2875cb4e85dc4baa30be5879e0af5d3d8810efb92bad95f2595d04c6cb0135fb96c600bf7031f352 SHA512 d4bf649d8a055ed3df52e19caf2424dc7e57d48182e9784bba2f9c7d6ebdd08b329c36fb26a28e6362bb5b24a39ea71f2604a64af471ce6245f464cafb6657cd
diff --git a/app-text/pandoc-bin/pandoc-bin-3.1.6.2.ebuild b/app-text/pandoc-bin/pandoc-bin-3.1.6.2.ebuild
new file mode 100644
index 000000000000..f5289c741e6a
--- /dev/null
+++ b/app-text/pandoc-bin/pandoc-bin-3.1.6.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN=${PN//-bin/}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Conversion between markup formats (binary package)"
+HOMEPAGE="https://pandoc.org/
+ https://github.com/jgm/pandoc/"
+
+BASE_URI="https://github.com/jgm/${MY_PN}/releases/download/${PV}/${MY_P}"
+SRC_URI="
+ amd64? ( ${BASE_URI}-linux-amd64.tar.gz )
+ arm64? ( ${BASE_URI}-linux-arm64.tar.gz )
+"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm64"
+IUSE="+pandoc-symlink"
+
+RDEPEND="pandoc-symlink? ( !${CATEGORY}/${MY_PN} )"
+
+QA_FLAGS_IGNORED="usr/bin/${PN}"
+QA_PRESTRIPPED="${QA_FLAGS_IGNORED}"
+
+src_unpack() {
+ default
+
+ # Manpages are gzipped.
+ unpack "${S}"/share/man/man1/*.1.gz
+}
+
+src_install() {
+ exeinto /usr/bin
+ newexe bin/${MY_PN} ${PN}
+ dosym ${PN} /usr/bin/pandoc-lua-bin
+ dosym ${PN} /usr/bin/pandoc-server-bin
+
+ newman "${WORKDIR}"/${MY_PN}-lua.1 pandoc-lua-bin.1
+ newman "${WORKDIR}"/${MY_PN}-server.1 pandoc-server-bin.1
+ newman "${WORKDIR}"/${MY_PN}.1 ${PN}.1
+
+ if use pandoc-symlink ; then
+ dosym ${PN} /usr/bin/${MY_PN}
+ dosym pandoc-lua-bin /usr/bin/${MY_PN}-lua
+ dosym pandoc-server-bin /usr/bin/${MY_PN}-server
+
+ dosym ${PN}.1 /usr/share/man/man1/${MY_PN}.1
+ dosym pandoc-lua-bin.1 /usr/share/man/man1/${MY_PN}-lua.1
+ dosym pandoc-server-bin.1 /usr/share/man/man1/${MY_PN}-server.1
+ fi
+}