summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOskari Pirhonen <xxc3ncoredxx@gmail.com>2022-11-21 23:47:33 -0600
committerSam James <sam@gentoo.org>2022-11-22 06:19:32 +0000
commitef84e0919788ca69ea7cfc8cc769c89ce46d030d (patch)
tree9e5a1200019ff79a81599b854b35721c4e6b2da0 /app-text/wgetpaste/wgetpaste-2.33-r1.ebuild
parentgnome-extra/cinnamon: drop 5.4.12 (diff)
downloadgentoo-ef84e0919788ca69ea7cfc8cc769c89ce46d030d.tar.gz
gentoo-ef84e0919788ca69ea7cfc8cc769c89ce46d030d.tar.bz2
gentoo-ef84e0919788ca69ea7cfc8cc769c89ce46d030d.zip
app-text/wgetpaste: use optfeature.eclass
Use optfeature.eclass to notify users about support for stripping ANSI codes and xclip integration if app-text/ansifilter and/or x11-misc/xclip are not installed, respectively. Signed-off-by: Oskari Pirhonen <xxc3ncoredxx@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/28379 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/wgetpaste/wgetpaste-2.33-r1.ebuild')
-rw-r--r--app-text/wgetpaste/wgetpaste-2.33-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-text/wgetpaste/wgetpaste-2.33-r1.ebuild b/app-text/wgetpaste/wgetpaste-2.33-r1.ebuild
new file mode 100644
index 000000000000..c8592f26415d
--- /dev/null
+++ b/app-text/wgetpaste/wgetpaste-2.33-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature
+
+DESCRIPTION="Command-line interface to various pastebins"
+HOMEPAGE="https://wgetpaste.zlin.dk/"
+SRC_URI="https://github.com/zlin/wgetpaste/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="+ssl"
+
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="net-misc/wget[ssl?]"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.33-tests.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i -e "s:/etc:\"${EPREFIX}\"/etc:g" wgetpaste || die
+}
+
+src_test() {
+ test/test.sh || die
+}
+
+src_install() {
+ dobin ${PN}
+ insinto /usr/share/zsh/site-functions
+ doins _wgetpaste
+}
+
+pkg_postinst() {
+ optfeature "ANSI (color code) stripping support" app-text/ansifilter
+ optfeature "xclip support" x11-misc/xclip
+}