summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-05-26 12:24:07 +0200
committerDavid Seifert <soap@gentoo.org>2018-05-26 12:42:40 +0200
commit8e9a6eb1d1f91d17cb1db87bcf146a53c6877664 (patch)
tree239f3f144eb99c1c448624269a662e8977ef9bf3 /app-text/wv2/wv2-0.4.2-r2.ebuild
parentprofiles: Remove webkit-gtk old slots notification mask (diff)
downloadgentoo-8e9a6eb1d1f91d17cb1db87bcf146a53c6877664.tar.gz
gentoo-8e9a6eb1d1f91d17cb1db87bcf146a53c6877664.tar.bz2
gentoo-8e9a6eb1d1f91d17cb1db87bcf146a53c6877664.zip
app-text/wv2: Force C++11
* Also port to EAPI 6 Closes: https://bugs.gentoo.org/653494 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-text/wv2/wv2-0.4.2-r2.ebuild')
-rw-r--r--app-text/wv2/wv2-0.4.2-r2.ebuild26
1 files changed, 15 insertions, 11 deletions
diff --git a/app-text/wv2/wv2-0.4.2-r2.ebuild b/app-text/wv2/wv2-0.4.2-r2.ebuild
index b13fed4fecb8..5f5d76cee7ef 100644
--- a/app-text/wv2/wv2-0.4.2-r2.ebuild
+++ b/app-text/wv2/wv2-0.4.2-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-inherit cmake-utils
+inherit cmake-utils flag-o-matic
DESCRIPTION="Excellent MS Word filter lib, used in most Office suites"
HOMEPAGE="http://wvware.sourceforge.net"
@@ -14,22 +14,26 @@ SLOT="0"
KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
IUSE="zlib"
-RDEPEND="dev-libs/glib
+RDEPEND="
+ dev-libs/glib
>=gnome-extra/libgsf-1.8:=
virtual/libiconv
- zlib? ( sys-libs/zlib )
-"
-DEPEND="${RDEPEND}"
+ zlib? ( sys-libs/zlib )"
+DEPEND="
+ ${RDEPEND}"
-DOCS=( AUTHORS ChangeLog README RELEASE THANKS TODO )
PATCHES=(
- "${FILESDIR}/${P}-glib.patch"
- "${FILESDIR}/${P}-libgsf.patch"
+ "${FILESDIR}"/${P}-glib.patch
+ "${FILESDIR}"/${P}-libgsf.patch
)
+DOCS=( AUTHORS ChangeLog README RELEASE THANKS TODO )
src_configure() {
+ # due to ICU 59 requiring C++11 now
+ append-cxxflags -std=c++11
+
local mycmakeargs=(
- $(cmake-utils_use_with zlib)
+ -DWITH_ZLIB=$(usex zlib)
)
cmake-utils_src_configure
}