summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-01-01 05:32:22 -0500
committerAnthony G. Basile <blueness@gentoo.org>2016-01-01 05:32:22 -0500
commite4b47b6983b3ef68c9461a8658ba7921e24ca199 (patch)
treeafc9e426b7d0b2fc6aa64b9dc89a4d5425d66e85 /app-text/xapian-omega/xapian-omega-1.3.4.ebuild
parentdev-libs/xapian: version bump to 1.3.4 (diff)
downloadgentoo-e4b47b6983b3ef68c9461a8658ba7921e24ca199.tar.gz
gentoo-e4b47b6983b3ef68c9461a8658ba7921e24ca199.tar.bz2
gentoo-e4b47b6983b3ef68c9461a8658ba7921e24ca199.zip
app-text/xapian-omega: version bump to 1.3.4
Package-Manager: portage-2.2.24
Diffstat (limited to 'app-text/xapian-omega/xapian-omega-1.3.4.ebuild')
-rw-r--r--app-text/xapian-omega/xapian-omega-1.3.4.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-text/xapian-omega/xapian-omega-1.3.4.ebuild b/app-text/xapian-omega/xapian-omega-1.3.4.ebuild
new file mode 100644
index 000000000000..74a655982e63
--- /dev/null
+++ b/app-text/xapian-omega/xapian-omega-1.3.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="An application built on Xapian, consisting of indexers and a CGI search frontend"
+SRC_URI="http://www.oligarchy.co.uk/xapian/${PV}/xapian-omega-${PV}.tar.xz"
+HOMEPAGE="http://www.xapian.org/"
+S="${WORKDIR}/xapian-omega-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="~dev-libs/xapian-${PV}
+ dev-lang/perl
+ dev-libs/libpcre
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+src_install () {
+ emake DESTDIR="${D}" install
+
+ #move docs to /usr/share/doc/${PF}.
+ mv "${D}/usr/share/doc/xapian-omega" "${D}/usr/share/doc/${PF}" || die
+
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
+}