summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-03-13 13:10:54 -0500
committerMatt Turner <mattst88@gentoo.org>2021-03-13 13:14:40 -0500
commit03f055cca3e93a63a61e389bf36a66c443a04d5a (patch)
tree3c1a9394793a1f7dc949d04b309f9e3fe5263b23 /app-text
parentsci-visualization/g3data: Port to EAPI 7 (diff)
downloadgentoo-03f055cca3e93a63a61e389bf36a66c443a04d5a.tar.gz
gentoo-03f055cca3e93a63a61e389bf36a66c443a04d5a.tar.bz2
gentoo-03f055cca3e93a63a61e389bf36a66c443a04d5a.zip
app-text/libgxps: Version bump to 0.3.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/libgxps/Manifest1
-rw-r--r--app-text/libgxps/libgxps-0.3.2.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-text/libgxps/Manifest b/app-text/libgxps/Manifest
index f29f25044cfb..eb4d77c773ba 100644
--- a/app-text/libgxps/Manifest
+++ b/app-text/libgxps/Manifest
@@ -1 +1,2 @@
DIST libgxps-0.3.1.tar.xz 93132 BLAKE2B 63af298ef1dc345ef7c40fae4006ba73aa7529381cc6cbc8cf86f4d5b69c8c5617b902bef833ed7d3fa968d927b441e888889179f598b06e2ca13084d3b199af SHA512 80401bd3c9753c74e425c5c08510cac314ad255ebeda9676bd5396a217770c7f5d8733c64b649cc6fdaa43423bb1a4ad21e1e0e3f7903f486e75a1d678850239
+DIST libgxps-0.3.2.tar.xz 79956 BLAKE2B 4e41361a90fe24816aff33e90dc1084d0c1c799a4c9368364e73d9a5df34a45be75bb9906ee272cd1956b3631894d4be63070cce57983e2401dc1496f08c3e33 SHA512 d3d56e4906477b68d088bf83bde666f9ea8bf383add592772aad53dd571e727f1bc0410dd020e12212ede5ff8e26cb46150a9860a6f7af29c4d195f03e946fe9
diff --git a/app-text/libgxps/libgxps-0.3.2.ebuild b/app-text/libgxps/libgxps-0.3.2.ebuild
new file mode 100644
index 000000000000..051579ab2eaf
--- /dev/null
+++ b/app-text/libgxps/libgxps-0.3.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org meson xdg-utils
+
+DESCRIPTION="Library for handling and rendering XPS documents"
+HOMEPAGE="https://wiki.gnome.org/Projects/libgxps"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="gtk-doc +introspection jpeg lcms tiff"
+
+RDEPEND="
+ >=app-arch/libarchive-2.8
+ >=dev-libs/glib-2.36:2
+ media-libs/freetype:2
+ media-libs/libpng:0
+ >=x11-libs/cairo-1.10[svg]
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+ jpeg? ( virtual/jpeg:0 )
+ lcms? ( media-libs/lcms:2 )
+ tiff? ( media-libs/tiff:0[zlib] )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ gtk-doc? ( dev-util/gtk-doc )
+ virtual/pkgconfig
+"
+
+# There is no automatic test suite, only an interactive test application
+RESTRICT="test"
+
+src_configure() {
+ local emesonargs=(
+ -Denable-test=false
+ $(meson_use gtk-doc enable-gtk-doc)
+ -Denable-man=true
+ -Ddisable-introspection=$(usex introspection false true)
+ $(meson_use lcms with-liblcms2)
+ $(meson_use jpeg with-libjpeg)
+ $(meson_use tiff with-libtiff)
+ )
+
+ xdg_environment_reset
+ meson_src_configure
+}