summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2023-10-02 01:17:35 -0400
committerZac Medico <zmedico@gentoo.org>2023-10-17 21:26:09 -0700
commit4103983d9ac27718dad9f5cbf9ea5bdf03aeb7ac (patch)
treee45812a8ca2b76b4cd2bc72b5f16bbcc7cb7a1e6 /app-text
parentapp-text/calibre: add support for packaging plugins in an ebuild (diff)
downloadgentoo-4103983d9ac27718dad9f5cbf9ea5bdf03aeb7ac.tar.gz
gentoo-4103983d9ac27718dad9f5cbf9ea5bdf03aeb7ac.tar.bz2
gentoo-4103983d9ac27718dad9f5cbf9ea5bdf03aeb7ac.zip
app-text/calibre: add verify-sig support
Historically, calibre has always supported this. Allow checking it. No revbump needed. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/calibre/calibre-5.44.0-r1.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/app-text/calibre/calibre-5.44.0-r1.ebuild b/app-text/calibre/calibre-5.44.0-r1.ebuild
index ba8f956e0af1..815415c38fea 100644
--- a/app-text/calibre/calibre-5.44.0-r1.ebuild
+++ b/app-text/calibre/calibre-5.44.0-r1.ebuild
@@ -6,11 +6,15 @@ EAPI=8
PYTHON_COMPAT=( python3_{9..11} )
PYTHON_REQ_USE="ipv6(+),sqlite,ssl"
-inherit toolchain-funcs python-single-r1 qmake-utils xdg-utils
+inherit toolchain-funcs python-single-r1 qmake-utils verify-sig xdg-utils
DESCRIPTION="Ebook management application"
HOMEPAGE="https://calibre-ebook.com/"
-SRC_URI="https://download.calibre-ebook.com/${PV}/${P}.tar.xz"
+SRC_URI="
+ https://download.calibre-ebook.com/${PV}/${P}.tar.xz
+ verify-sig? ( https://calibre-ebook.com/signatures/${P}.tar.xz.sig )
+"
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}/usr/share/openpgp-keys/kovidgoyal.gpg"
LICENSE="
GPL-3+
@@ -115,7 +119,9 @@ BDEPEND="$(python_gen_cond_dep '
')
>=virtual/podofo-build-0.9.6_pre20171027
<virtual/podofo-build-0.10
- virtual/pkgconfig"
+ virtual/pkgconfig
+ verify-sig? ( sec-keys/openpgp-keys-kovidgoyal )
+"
PATCHES=(
# Don't prompt the user for updates - they've installed via