summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-08-21 11:37:33 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-08-21 11:37:33 +0200
commit46153817ff946616e9cb6915b10aa8501673a5cb (patch)
tree996887adbec75ac547245f00205ea8687e2bcc50 /app-text
parentgames-action/minecraft-launcher: EAPI bump, add missing dep (diff)
downloadgentoo-46153817ff946616e9cb6915b10aa8501673a5cb.tar.gz
gentoo-46153817ff946616e9cb6915b10aa8501673a5cb.tar.bz2
gentoo-46153817ff946616e9cb6915b10aa8501673a5cb.zip
app-text/zotero-bin: add version 5.0.96.3
Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/zotero-bin/Manifest1
-rw-r--r--app-text/zotero-bin/zotero-bin-5.0.96.3.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/app-text/zotero-bin/Manifest b/app-text/zotero-bin/Manifest
index a3f13bd62998..1d17b0e7ac17 100644
--- a/app-text/zotero-bin/Manifest
+++ b/app-text/zotero-bin/Manifest
@@ -1 +1,2 @@
DIST zotero-bin-5.0.96.2.tar.bz2 60475436 BLAKE2B 2c113fbbb78f0e4ca4e12ed31ed43ba6e65eea88039f9fda1d1f97e6407b95e9ac1d89b2504f220ce96634f5404defcdb5f5346dec83d5d9f02832e1573f1a60 SHA512 4fc988bf74179ad5f28a4649cfc6c6c5d4eeabc3b7aa60e717681bc57dd1c3ba6f2d3310fb83e6e2e55475aa9d7077329acc3dff52b63a0759c32f542ef0ef47
+DIST zotero-bin-5.0.96.3.tar.bz2 61236517 BLAKE2B 3de6d41349f9cc405dd3d44e8e456169d58bdd1f4522c31cd168182878839fe8ca6280eff7339bcf3d66c87c7d4f5af55d768551abcff3cd579342cae37b64e3 SHA512 0777ec41bc151b0bd30076f8a7f59e431c3435728b4d85298421ef11aea5b7c1e122d3bb7fcc5551bb8c4472922796d9508a56df7a0913515d8568fcf3ca6fee
diff --git a/app-text/zotero-bin/zotero-bin-5.0.96.3.ebuild b/app-text/zotero-bin/zotero-bin-5.0.96.3.ebuild
new file mode 100644
index 000000000000..561cabf9e7f0
--- /dev/null
+++ b/app-text/zotero-bin/zotero-bin-5.0.96.3.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop xdg
+
+DESCRIPTION="Helps you collect, organize, cite, and share your research sources"
+HOMEPAGE="https://www.zotero.org"
+SRC_URI="https://www.zotero.org/download/client/dl?channel=release&platform=linux-x86_64&version=${PV} -> ${P}.tar.bz2"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+RDEPEND="
+ dev-libs/atk
+ dev-libs/dbus-glib
+ dev-libs/glib
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/fontconfig
+ media-libs/freetype
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrender
+ x11-libs/libXt
+ x11-libs/pango
+"
+
+S="${WORKDIR}/Zotero_linux-x86_64"
+
+QA_PREBUILT="/opt/zotero/*"
+
+src_prepare() {
+ # disable auto-update
+ sed -i -e 's/\(pref("app.update.enabled"\).*/\1, false);/' defaults/preferences/prefs.js || die
+
+ # disable default oo installation questions - manual installation is still possible
+ sed -i -e 's/\(pref("extensions.zoteroOpenOfficeIntegration.skipInstallation"\).*/\1, true);/' \
+ extensions/zoteroOpenOfficeIntegration@zotero.org/defaults/preferences/zoteroOpenOfficeIntegration.js || die
+
+ # fix desktop-file
+ sed -i -e 's#^Exec=.*#Exec=zotero#' zotero.desktop
+ sed -i -e 's#Icon=zotero.*#Icon=zotero#' zotero.desktop
+
+ default
+}
+
+src_install() {
+ dodir opt/zotero
+ cp -a "${S}"/* "${ED}/opt/zotero" || die
+
+ dosym ../../opt/zotero/zotero usr/bin/zotero
+
+ domenu zotero.desktop
+
+ for size in 16 32 48 256; do
+ newicon -s ${size} chrome/icons/default/default${size}.png zotero.png
+ done
+}