summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2022-02-21 12:51:02 +0700
committerAndrey Grozin <grozin@gentoo.org>2022-02-21 12:51:02 +0700
commit812baa73db4c66f05f2e2afd102ef7282074f74a (patch)
tree11e96bf98f05dcfb99e9c0102ccdf57a8345d850 /app-text
parentapp-admin/system-config-printer: Version bump to 1.5.16 (diff)
downloadgentoo-812baa73db4c66f05f2e2afd102ef7282074f74a.tar.gz
gentoo-812baa73db4c66f05f2e2afd102ef7282074f74a.tar.bz2
gentoo-812baa73db4c66f05f2e2afd102ef7282074f74a.zip
app-text/foliate: ebuild improvements
Closes: https://bugs.gentoo.org/800560 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/foliate/foliate-2.6.4-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-text/foliate/foliate-2.6.4-r1.ebuild b/app-text/foliate/foliate-2.6.4-r1.ebuild
new file mode 100644
index 000000000000..155e34657ae2
--- /dev/null
+++ b/app-text/foliate/foliate-2.6.4-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PLOCALES="cs de es eu fr id ie it ko nb nl nn pt_BR ru sv tr uk zh_CN zh_TW"
+PYTHON_COMPAT=( python3_{8..10} )
+inherit meson python-any-r1 plocale xdg gnome2-utils
+SRC_URI="https://github.com/johnfactotum/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+DESCRIPTION="gtk ebook reader built with gjs"
+HOMEPAGE="https://github.com/johnfactotum/foliate/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="handy spell"
+
+BDEPEND="${MESON_DEPEND}
+ sys-devel/gettext"
+RDEPEND="dev-libs/gjs
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ net-libs/webkit-gtk:4[introspection]
+ handy? ( gui-libs/libhandy:=[introspection] )
+ spell? ( app-text/gspell[introspection] )"
+
+src_prepare() {
+ default
+ python_fix_shebang build-aux/meson
+ xdg_environment_reset
+
+ plocale_find_changes "${S}"/po '' '.po'
+
+ rm_po() {
+ rm po/${1}.po
+ sed -e "/^${1}/d" -i po/LINGUAS
+ }
+
+ plocale_for_each_disabled_locale rm_po
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}