summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-01-17 11:41:26 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-01-17 11:42:33 +0100
commit837904c238c661f98329d58fe545e2240277aff6 (patch)
tree602fcb1a70db3aae67d447d34658c3059597df31 /app-text
parentwww-client/firefox: toggle real-time-tracing configure option (diff)
downloadgentoo-837904c238c661f98329d58fe545e2240277aff6.tar.gz
gentoo-837904c238c661f98329d58fe545e2240277aff6.tar.bz2
gentoo-837904c238c661f98329d58fe545e2240277aff6.zip
app-text/zotero-bin: add 6.0.20
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/zotero-bin/Manifest2
-rw-r--r--app-text/zotero-bin/zotero-bin-6.0.20.ebuild87
2 files changed, 89 insertions, 0 deletions
diff --git a/app-text/zotero-bin/Manifest b/app-text/zotero-bin/Manifest
index 010c9ebd28ca..77744b75cd45 100644
--- a/app-text/zotero-bin/Manifest
+++ b/app-text/zotero-bin/Manifest
@@ -2,3 +2,5 @@ DIST zotero-bin-6.0.18-amd64.tar.bz2 69200236 BLAKE2B c1dc30b1c29565286606874205
DIST zotero-bin-6.0.18-x86.tar.bz2 70892698 BLAKE2B 49f23ef1d2a682bb945bf4b43c52e05551414597e6d16b89cefcd07588d158d917c63a7014d23969b5590caf2c79bc8875d03e9e6b2d709ce168acd8420435b6 SHA512 d7c70336a66c208f636ea4c96fde3b1e6547b7f1422a328f24f1ab2e2f25fce21d0ab69a98c787d9ffaa6f70e02995231365c07bf8da0f145adec875d008aa84
DIST zotero-bin-6.0.19-amd64.tar.bz2 69255233 BLAKE2B b52b2d540e3a5ac2aa949d4f313bd83934a2c086ec56be0817f01f6518de1c3c10e991d8820cede4254ab2250d36ca5fc62353476832502efbc69aa92597d604 SHA512 4b18448b1f12ef52454cfb1ad44b724eb4fd6ae5a90c65703919ead460fb87c0c776ec610b057e0ff80b889d01c23c4a4264ea38d26f9074761deeb63406f51e
DIST zotero-bin-6.0.19-x86.tar.bz2 70911732 BLAKE2B d409d993551836ffc09f3e3b33a1b24055d409faa9137facb25500d13d12cbfaf59893ffaac60a4e8bef4d2ac2d8806eaad1b0c8255162c1e0e75b674c35b0f9 SHA512 e1bba3cc1c1f39d0eec0d8d26d16e26a9142e5c255a52e63ccf78b5341596619ca104610507bc2086f57c5da975c70bec43020cf0dfcb0bce6ad0f8b42e169bb
+DIST zotero-bin-6.0.20-amd64.tar.bz2 69268379 BLAKE2B 126c1499e375726cc25fb5ebe366137e11dfc288ac9e0d93680459e602378400419f82cc4ed6556d10973e1928c89a8711ac369203d221be94a291340a3f1f11 SHA512 c054d3bf344bb8ca5a762ef99d5e214158de02f70f248ca28a9a345273edfa9e93525e0cd70e2c2eeb7039714e310e6b24d04268eb608087cab738b849200b4b
+DIST zotero-bin-6.0.20-x86.tar.bz2 70930545 BLAKE2B 96c3b2df646fdd0401f1b7a6deb7061fe5c517e8a95f3c6cdcd8686473f12fc51f7847029784d827f929745d3e660b57d7de783e82809ce76f8868335f0d10ec SHA512 9ac5b251db998e0ba8a838441111c9e4c994feee40608bf2a7e6dc1b6d50a7585d6d9a9ffa4ba0aa1afbde94b2cfc4a32522d4bf79255cef729634354ebd76ab
diff --git a/app-text/zotero-bin/zotero-bin-6.0.20.ebuild b/app-text/zotero-bin/zotero-bin-6.0.20.ebuild
new file mode 100644
index 000000000000..07c557e6c051
--- /dev/null
+++ b/app-text/zotero-bin/zotero-bin-6.0.20.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop xdg
+
+DESCRIPTION="Helps you collect, organize, cite, and share your research sources"
+HOMEPAGE="https://www.zotero.org"
+SRC_URI="
+ amd64? ( https://www.zotero.org/download/client/dl?channel=release&platform=linux-x86_64&version=${PV} -> ${P}-amd64.tar.bz2 )
+ x86? ( https://www.zotero.org/download/client/dl?channel=release&platform=linux-i686&version=${PV} -> ${P}-x86.tar.bz2 )
+"
+S="${WORKDIR}"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+RDEPEND="
+ app-accessibility/at-spi2-core
+ dev-libs/dbus-glib
+ dev-libs/glib
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/fontconfig
+ media-libs/freetype
+ sys-apps/dbus
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrender
+ x11-libs/libXt
+ x11-libs/pango
+"
+
+QA_PREBUILT="opt/zotero/*"
+
+src_prepare() {
+ if use amd64; then
+ cd Zotero_linux-x86_64 || die
+ elif use x86; then
+ cd Zotero_linux-i686 || die
+ fi
+
+ # disable auto-update
+ sed -i -e 's/\(pref("app.update.enabled"\).*/\1, false);/' defaults/preferences/prefs.js || die
+
+ # disable default oo installation questions - manual installation is still possible
+ sed -i -e 's/\(pref("extensions.zoteroOpenOfficeIntegration.skipInstallation"\).*/\1, true);/' \
+ extensions/zoteroOpenOfficeIntegration@zotero.org/defaults/preferences/zoteroOpenOfficeIntegration.js || die
+
+ # fix desktop-file
+ sed -i -e 's#^Exec=.*#Exec=zotero#' zotero.desktop || die
+ sed -i -e 's#Icon=zotero.*#Icon=zotero#' zotero.desktop || die
+
+ default
+}
+
+src_install() {
+ if use amd64; then
+ cd Zotero_linux-x86_64 || die
+ elif use x86; then
+ cd Zotero_linux-i686 || die
+ fi
+
+ dodir opt/zotero
+ cp -a * "${ED}/opt/zotero" || die
+
+ dosym ../../opt/zotero/zotero usr/bin/zotero
+
+ domenu zotero.desktop
+
+ for size in 16 32 48 256; do
+ newicon -s ${size} chrome/icons/default/default${size}.png zotero.png
+ done
+}