summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2023-05-31 10:28:51 -0400
committerMichael Orlitzky <mjo@gentoo.org>2023-05-31 10:29:43 -0400
commit8c9f0040276efa1f0d2b212e8631c439337d6804 (patch)
tree3e14305f6ff381cbaf066e927f650e4bd88a80e7 /app-text
parentwww-apache/mod_h2: drop 2.0.17 (diff)
downloadgentoo-8c9f0040276efa1f0d2b212e8631c439337d6804.tar.gz
gentoo-8c9f0040276efa1f0d2b212e8631c439337d6804.tar.bz2
gentoo-8c9f0040276efa1f0d2b212e8631c439337d6804.zip
app-text/diff-pdf: add 0.5.1
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/diff-pdf/Manifest1
-rw-r--r--app-text/diff-pdf/diff-pdf-0.5.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/app-text/diff-pdf/Manifest b/app-text/diff-pdf/Manifest
index 9486bceaf457..9e596b1afd90 100644
--- a/app-text/diff-pdf/Manifest
+++ b/app-text/diff-pdf/Manifest
@@ -1 +1,2 @@
+DIST diff-pdf-0.5.1.tar.gz 142541 BLAKE2B db402ee9c0d3013b76b5e20381d661c572206bd834e5ec31824dc9f4aed08e0fcb1d57909b4a7490297c767aaf17efdd522ca4488c63a276ba6fb3f50e74b8b9 SHA512 8f2669da974912023208cdb538256ff979935d64e1f32d547da33d6c8231945ae555f6f85481ef36ec888d3ceda7fdfdddcfbd225f0a891c5f1613be6f249f4f
DIST diff-pdf-0.5.tar.gz 135755 BLAKE2B e4b9599b4f443171473ef483fe868c58e0a0c9f23838895aa08f1bd662c4df920fdb50277d2d0a5b28d5bb66054e700012a98be636a12d34ec919ad85d332cc0 SHA512 62a868118fc807b433e504edfefdc6a9598a8197aaf5cd4e46451b67d5d73fcf9234bd6efbe6307ed7c3821aabef8edea81cbb0bbe5f4d34365c5f8d6dd9a51d
diff --git a/app-text/diff-pdf/diff-pdf-0.5.1.ebuild b/app-text/diff-pdf/diff-pdf-0.5.1.ebuild
new file mode 100644
index 000000000000..a02e905054c1
--- /dev/null
+++ b/app-text/diff-pdf/diff-pdf-0.5.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.2-gtk3"
+inherit wxwidgets
+
+DESCRIPTION="A simple tool for visually comparing two PDF files"
+HOMEPAGE="https://vslavik.github.io/diff-pdf/ https://github.com/vslavik/diff-pdf/"
+SRC_URI="https://github.com/vslavik/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+# The COPYING.icons file states that two icons were taken from
+# version 2.16.5 of GTK+, which is licensed LGPL-2+.
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+# The build system checks for "poppler-glib", which is provided only
+# when app-text/poppler is built with USE=cairo. Moreover the glib ABI
+# of poppler is relatively stable, and I can only assume that diff-pdf
+# uses that rather than the low-level libpoppler.so API. Since the
+# subslot on app-text/poppler is ONLY for the low-level API, we
+# therefore don't need a subslot dependency on app-text/poppler.
+#
+# Since diff-pdf.cpp includes glib.h directly, I've included
+# dev-libs/glib as an explicit dependency. Ditto for x11-libs/cairo.
+DEPEND="app-text/poppler[cairo]
+ dev-libs/glib
+ x11-libs/cairo
+ x11-libs/wxGTK:${WX_GTK_VER}[X]"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ setup-wxwidgets
+ default
+}