summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-04-06 15:48:33 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-04-06 15:59:26 +0300
commitb934ea6c3df7976c73219667d4b118365b4fc113 (patch)
tree2d8fb2779700aa5052407a30a954a030a282e68a /app-text
parentnet-im/telegram-desktop: drop 4.14.15 (diff)
downloadgentoo-b934ea6c3df7976c73219667d4b118365b4fc113.tar.gz
gentoo-b934ea6c3df7976c73219667d4b118365b4fc113.tar.bz2
gentoo-b934ea6c3df7976c73219667d4b118365b4fc113.zip
app-text/vgrep: add 2.7.0
Closes: https://bugs.gentoo.org/795345 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/vgrep/Manifest1
-rw-r--r--app-text/vgrep/vgrep-2.7.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-text/vgrep/Manifest b/app-text/vgrep/Manifest
index 9f8a1d57e833..dfc67e995979 100644
--- a/app-text/vgrep/Manifest
+++ b/app-text/vgrep/Manifest
@@ -1 +1,2 @@
DIST vgrep-2.6.0.tar.gz 1589155 BLAKE2B 847954ccf020c2b7f54360aab2fd9e3fc897dfd3ceab7d9ecd79f378c18196048649b37f4f9b62dc8f2af46f874a8433c8a20e5e025ca9e0f08b8f6859b0dd40 SHA512 712ca1ab4318a69fbb9f0e60343c188b292c59c52ca488adb1db546937822b0e49a49541e2b9e69cec6b721003198518f530521f4c726988516bcd64e7247846
+DIST vgrep-2.7.0.tar.gz 1998937 BLAKE2B 8f5bf53814604ff3bdf7492ec8ad96811a62c9accc0664d07db86039e117686f551c6aaba40e5af4e1b646289a0e996b4f1cade9fc1a197778504e5c8d114830 SHA512 5cc9e866c6de9b024d29dc9aeeb87d6eea23becde63968b2a9266412bbe44920fa13d5e7dda47bb46135301ff7f5fd79e02ec2da8a9a694183d9e63aad64478d
diff --git a/app-text/vgrep/vgrep-2.7.0.ebuild b/app-text/vgrep/vgrep-2.7.0.ebuild
new file mode 100644
index 000000000000..eac568a4d663
--- /dev/null
+++ b/app-text/vgrep/vgrep-2.7.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="A pager for grep, git-grep and similar grep implementations"
+HOMEPAGE="https://github.com/vrothberg/vgrep"
+SRC_URI="https://github.com/vrothberg/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD GPL-3 MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# tests just run golangci-lint
+RESTRICT="test"
+
+BDEPEND="dev-go/go-md2man"
+
+DOCS=( README.md )
+
+src_prepare() {
+ default
+ sed -e '/-ldflags/s/-s //' -i Makefile || die # bug 795345
+}
+
+src_compile() {
+ emake build
+}
+
+src_install() {
+ emake PREFIX="${ED}/usr" install
+ einstalldocs
+}