summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-09-29 19:11:58 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-09-29 19:23:37 +0300
commitc7b10102cfb661d0ed239659ef1b969c7c2db0b4 (patch)
tree9e76e32388380ff3e36367ceb6b05162f5e9b77b /app-text
parentapp-misc/fdupes: sync live (diff)
downloadgentoo-c7b10102cfb661d0ed239659ef1b969c7c2db0b4.tar.gz
gentoo-c7b10102cfb661d0ed239659ef1b969c7c2db0b4.tar.bz2
gentoo-c7b10102cfb661d0ed239659ef1b969c7c2db0b4.zip
app-text/dos2unix: add 7.5.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/dos2unix/Manifest1
-rw-r--r--app-text/dos2unix/dos2unix-7.5.2.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/app-text/dos2unix/Manifest b/app-text/dos2unix/Manifest
index c3777c9a88a1..0e7a78503561 100644
--- a/app-text/dos2unix/Manifest
+++ b/app-text/dos2unix/Manifest
@@ -1,2 +1,3 @@
DIST dos2unix-7.5.0.tar.gz 957576 BLAKE2B 5a674d61c9f911a2cb9c20c363fdc0e0affd3b6f26531d37a231aedb5e6a7428116b139d4af12ee32f4107f78ea079fb7a8d008c9630375f4afbc2afa0afb39f SHA512 914cbc3255045b1b87ad702c70844b059f9435ccfe636dc67514f092090b86a9f271789fcde28a9ead4d94a869fb92e334aa115d3cfe24133338260ad2233763
DIST dos2unix-7.5.1.tar.gz 959228 BLAKE2B 4f4a334a295b702d0540e58a0a86dcf091583d6c2b64f6de9bea883dfe0d70bfa05e8e5b9c8fb867bfd5e66b2eba562da1ca45c60f97bac67bdb275d66de0fe0 SHA512 733d163fff4effdf8acb382abec9bcd23f594fa17502e9dde2f24d3326aeb7653eee353bef812090ab8dc055136d236b40c2f778deea4ac026c2eed471e763b5
+DIST dos2unix-7.5.2.tar.gz 991485 BLAKE2B 2d88e88960d5deb6531b6eb52f646d0c8f40c361800e2f26632577e9187999599752d30b0c7e4e1f18c0127578311b8be6910e54535c333e092c3ebb70329173 SHA512 d76d799435dd248850f72cc50af2144a51e99f04ea83a1447c4edd828625c83f0afba367da51aa83defced4cbf34f3b75387a0821010f7b212225571036efbb2
diff --git a/app-text/dos2unix/dos2unix-7.5.2.ebuild b/app-text/dos2unix/dos2unix-7.5.2.ebuild
new file mode 100644
index 000000000000..1f2978127daa
--- /dev/null
+++ b/app-text/dos2unix/dos2unix-7.5.2.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PLOCALES="ca da de eo es fr fur hu ja ka ko nb nl pl pt_BR ro ru sr sv uk vi zh_CN zh_TW"
+
+inherit plocale toolchain-funcs
+
+DESCRIPTION="Convert DOS or MAC text files to UNIX format or vice versa"
+HOMEPAGE="https://www.xs4all.nl/~waterlan/dos2unix.html https://sourceforge.net/projects/dos2unix/"
+SRC_URI="
+ https://www.xs4all.nl/~waterlan/${PN}/${P/_/-}.tar.gz
+ https://downloads.sourceforge.net/${PN}/${P/_/-}.tar.gz
+"
+S=${WORKDIR}/${P/_/-}
+
+LICENSE="BSD-2"
+SLOT="0"
+[[ "${PV}" == *_beta* ]] || \
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="debug nls test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ !app-text/hd2u
+ virtual/libintl
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( virtual/perl-Test-Simple )
+"
+BDEPEND="
+ dev-lang/perl
+ nls? ( sys-devel/gettext )
+"
+
+handle_locales() {
+ # Make sure locale list is kept up-to-date.
+ local detected sorted
+ detected=$(echo $(printf '%s\n' */*.po | sed -e 's:.*/::' -e 's:.po$::' | sort -u))
+ sorted=$(echo $(printf '%s\n' ${PLOCALES} | sort -u))
+ if [[ ${sorted} != "${detected}" ]] ; then
+ eerror "The ebuild needs to be kept in sync."
+ eerror "PLOCALES: ${sorted}"
+ eerror "po*/*.po: ${detected}"
+ die "sync PLOCALES"
+ fi
+
+ # Deal with selective install of locales.
+ rm_loc() { rm po*/$1.po || die; }
+ plocale_for_each_disabled_locale rm_loc
+}
+
+src_prepare() {
+ default
+
+ handle_locales
+
+ sed \
+ -e '/^LDFLAGS/s|=|+=|' \
+ -e '/CFLAGS_OS \+=/d' \
+ -e '/LDFLAGS_EXTRA \+=/d' \
+ -e "/^CFLAGS/s|-O2|${CFLAGS}|" \
+ -i Makefile || die
+
+ if use debug ; then
+ sed -e "/^DEBUG/s:0:1:" \
+ -e "/EXTRA_CFLAGS +=/s:-g::" \
+ -i Makefile || die
+ fi
+
+ tc-export CC
+}
+
+lintl() {
+ # same logic as from virtual/libintl
+ use !elibc_glibc && use !elibc_musl && echo "-lintl"
+}
+
+src_compile() {
+ emake prefix="${EPREFIX}/usr" \
+ $(usex nls "LDFLAGS_EXTRA=$(lintl)" "ENABLE_NLS=")
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="${EPREFIX}/usr" \
+ $(usex nls "" "ENABLE_NLS=") install
+}