summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-01-19 10:46:40 +0000
committerSam James <sam@gentoo.org>2024-01-19 10:46:40 +0000
commitf63293f0b9f2a9d167ad811188daab93f9295c48 (patch)
tree45c8a22c7202e8a6820dc809e0894c0faa32a94f /app-text
parentsys-process/cronie: backport envelope revert (diff)
downloadgentoo-f63293f0b9f2a9d167ad811188daab93f9295c48.tar.gz
gentoo-f63293f0b9f2a9d167ad811188daab93f9295c48.tar.bz2
gentoo-f63293f0b9f2a9d167ad811188daab93f9295c48.zip
app-text/ghostscript-gpl: another modern C fix
Closes: https://bugs.gentoo.org/922448 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/ghostscript-gpl/files/ghostscript-gpl-10.02.1-c99-2.patch53
-rw-r--r--app-text/ghostscript-gpl/ghostscript-gpl-10.02.1-r1.ebuild199
2 files changed, 252 insertions, 0 deletions
diff --git a/app-text/ghostscript-gpl/files/ghostscript-gpl-10.02.1-c99-2.patch b/app-text/ghostscript-gpl/files/ghostscript-gpl-10.02.1-c99-2.patch
new file mode 100644
index 000000000000..a9356f861c52
--- /dev/null
+++ b/app-text/ghostscript-gpl/files/ghostscript-gpl-10.02.1-c99-2.patch
@@ -0,0 +1,53 @@
+https://bugs.gentoo.org/922448
+https://bugs.ghostscript.com/show_bug.cgi?id=707502
+https://git.ghostscript.com/?p=ghostpdl.git;h=8f5c77af6c0b84bdea719010cf4f67877e857b2b
+
+From 8f5c77af6c0b84bdea719010cf4f67877e857b2b Mon Sep 17 00:00:00 2001
+From: Ken Sharp <Ken.Sharp@artifex.com>
+Date: Fri, 19 Jan 2024 08:44:33 +0000
+Subject: [PATCH] X device - fix compiler 'warning'
+
+Bug #707502 "- -Wincompatible-pointer-types warning in devices/gdevxini.c"
+
+This is probably an oversight from when we changed a load of variables
+to size_t.
+
+Seems odd that compilers (well gcc) should refuse to compile becuase of
+a warning, but that's compilers. The pointer type is incorrect so let's
+fix it.
+--- a/devices/gdevx.h
++++ b/devices/gdevx.h
+@@ -1,4 +1,4 @@
+-/* Copyright (C) 2001-2023 Artifex Software, Inc.
++/* Copyright (C) 2001-2024 Artifex Software, Inc.
+ All Rights Reserved.
+
+ This software is provided AS-IS with no warranty, either express or
+@@ -39,7 +39,7 @@ typedef struct gx_device_X_s {
+ bool is_buffered;
+ bool IsPageDevice;
+ byte *buffer; /* full-window image */
+- long buffer_size;
++ size_t buffer_size;
+ gx_device_color_info orig_color_info;
+
+ /* An XImage object for writing bitmap images to the screen */
+--- a/devices/gdevxini.c
++++ b/devices/gdevxini.c
+@@ -1,4 +1,4 @@
+-/* Copyright (C) 2001-2023 Artifex Software, Inc.
++/* Copyright (C) 2001-2024 Artifex Software, Inc.
+ All Rights Reserved.
+
+ This software is provided AS-IS with no warranty, either express or
+@@ -621,7 +621,7 @@ x_set_buffer(gx_device_X * xdev)
+ }
+ if (mdev->width != xdev->width || mdev->height != xdev->height) {
+ byte *buffer;
+- ulong space;
++ size_t space;
+
+ if (gdev_mem_data_size(mdev, xdev->width, xdev->height, &space) < 0 ||
+ space > xdev->space_params.MaxBitmap) {
+--
+2.34.1
diff --git a/app-text/ghostscript-gpl/ghostscript-gpl-10.02.1-r1.ebuild b/app-text/ghostscript-gpl/ghostscript-gpl-10.02.1-r1.ebuild
new file mode 100644
index 000000000000..bd7de413886b
--- /dev/null
+++ b/app-text/ghostscript-gpl/ghostscript-gpl-10.02.1-r1.ebuild
@@ -0,0 +1,199 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic toolchain-funcs
+
+MY_PN=${PN/-gpl}
+MY_P="${MY_PN}-${PV/_}"
+PVM=$(ver_cut 1-2)
+PVM_S=$(ver_rs 1-2 "")
+
+# Use https://gitweb.gentoo.org/proj/codec/ghostscript-gpl-patches.git/ for patches
+# See 'index' branch for README
+MY_PATCHSET="ghostscript-gpl-10.0-patches.tar.xz"
+
+DESCRIPTION="Interpreter for the PostScript language and PDF"
+HOMEPAGE="https://ghostscript.com/ https://git.ghostscript.com/?p=ghostpdl.git;a=summary"
+SRC_URI="https://github.com/ArtifexSoftware/ghostpdl-downloads/releases/download/gs${PVM_S}/${MY_P}.tar.xz"
+if [[ -n "${MY_PATCHSET}" ]] ; then
+ SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${MY_PATCHSET}"
+fi
+
+LICENSE="AGPL-3 CPL-1.0"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="cups dbus gtk l10n_de static-libs unicode X"
+
+LANGS="ja ko zh-CN zh-TW"
+for X in ${LANGS} ; do
+ IUSE="${IUSE} l10n_${X}"
+done
+
+DEPEND="
+ app-text/libpaper:=
+ media-libs/fontconfig
+ >=media-libs/freetype-2.4.9:2=
+ >=media-libs/jbig2dec-0.19:=
+ >=media-libs/lcms-2.6:2
+ >=media-libs/libpng-1.6.2:=
+ media-libs/libjpeg-turbo:=
+ >=media-libs/openjpeg-2.1.0:2=
+ >=media-libs/tiff-4.0.1:=
+ >=sys-libs/zlib-1.2.7
+ cups? ( >=net-print/cups-1.3.8 )
+ dbus? ( sys-apps/dbus )
+ gtk? ( x11-libs/gtk+:3 )
+ unicode? ( net-dns/libidn:= )
+ X? ( x11-libs/libXt x11-libs/libXext )
+"
+BDEPEND="virtual/pkgconfig"
+# bug #844115 for newer poppler-data dep
+RDEPEND="
+ ${DEPEND}
+ >=app-text/poppler-data-0.4.11-r2
+ >=media-fonts/urw-fonts-2.4.9
+ l10n_ja? ( media-fonts/kochi-substitute )
+ l10n_ko? ( media-fonts/baekmuk-fonts )
+ l10n_zh-CN? ( media-fonts/arphicfonts )
+ l10n_zh-TW? ( media-fonts/arphicfonts )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-10.02.1-c99.patch
+ "${FILESDIR}"/${PN}-10.02.1-c99-2.patch
+)
+
+src_prepare() {
+ if [[ -n ${MY_PATCHSET} ]] ; then
+ # apply various patches, many borrowed from Fedora
+ # https://src.fedoraproject.org/rpms/ghostscript
+ # and Debian
+ # https://salsa.debian.org/printing-team/ghostscript/-/tree/debian/latest/debian/patches
+ eapply "${WORKDIR}"/${MY_PATCHSET%%.tar*}
+ fi
+
+ default
+
+ # Remove internal copies of various libraries
+ rm -r cups/libs || die
+ rm -r freetype || die
+ rm -r jbig2dec || die
+ rm -r jpeg || die
+ rm -r lcms2mt || die
+ rm -r libpng || die
+ rm -r tiff || die
+ rm -r zlib || die
+ rm -r openjpeg || die
+ # Remove internal CMaps (CMaps from poppler-data are used instead)
+ rm -r Resource/CMap || die
+
+ if ! use gtk ; then
+ sed -e "s:\$(GSSOX)::" \
+ -e "s:.*\$(GSSOX_XENAME)$::" \
+ -i base/unix-dll.mak || die "sed failed"
+ fi
+
+ # Force the include dirs to a neutral location.
+ sed -e "/^ZLIBDIR=/s:=.*:=${T}:" \
+ -i configure.ac || die
+ # Some files depend on zlib.h directly. Redirect them. #573248
+ # Also make sure to not define OPJ_STATIC to avoid linker errors due to
+ # hidden symbols (https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=203327#c1)
+ sed -e '/^zlib_h/s:=.*:=:' \
+ -e 's|-DOPJ_STATIC ||' \
+ -i base/lib.mak || die
+
+ # Search path fix
+ # put LDFLAGS after BINDIR, bug #383447
+ sed -e "s:\$\(gsdatadir\)/lib:@datarootdir@/ghostscript/${PV}/$(get_libdir):" \
+ -e "s:exdir=.*:exdir=@datarootdir@/doc/${PF}/examples:" \
+ -e "s:docdir=.*:docdir=@datarootdir@/doc/${PF}/html:" \
+ -e "s:GS_DOCDIR=.*:GS_DOCDIR=@datarootdir@/doc/${PF}/html:" \
+ -e 's:-L$(BINDIR):& $(LDFLAGS):g' \
+ -i Makefile.in base/*.mak || die "sed failed"
+
+ # Remove incorrect symlink, bug 590384
+ rm ijs/ltmain.sh || die
+ eautoreconf
+
+ cd ijs || die
+ eautoreconf
+}
+
+src_configure() {
+ # Unsupported upstream, bug #884841
+ filter-lto
+
+ local FONTPATH
+ for path in \
+ "${EPREFIX}"/usr/share/fonts/urw-fonts \
+ "${EPREFIX}"/usr/share/fonts/Type1 \
+ "${EPREFIX}"/usr/share/fonts
+ do
+ FONTPATH="${FONTPATH}${FONTPATH:+:}${EPREFIX}${path}"
+ done
+
+ # Do not add --enable-dynamic here, it's not supported fully upstream
+ # https://bugs.ghostscript.com/show_bug.cgi?id=705895
+ # bug #884707
+ #
+ # leptonica and tesseract are bundled but modified upstream, like in
+ # mujs/mupdf.
+ PKGCONFIG=$(type -P $(tc-getPKG_CONFIG)) econf \
+ --enable-freetype \
+ --enable-fontconfig \
+ --enable-openjpeg \
+ --disable-compile-inits \
+ --with-drivers=ALL \
+ --with-fontpath="${FONTPATH}" \
+ --with-ijs \
+ --with-jbig2dec \
+ --with-libpaper \
+ --with-system-libtiff \
+ $(use_enable cups) \
+ $(use_enable dbus) \
+ $(use_enable gtk) \
+ $(use_with cups pdftoraster) \
+ $(use_with unicode libidn) \
+ $(use_with X x) \
+ DARWIN_LDFLAGS_SO_PREFIX="${EPREFIX}/usr/lib/"
+
+ cd "${S}/ijs" || die
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake so all
+
+ cd ijs || die
+ emake
+}
+
+src_install() {
+ emake DESTDIR="${D}" install-so install
+
+ # move gsc to gs, bug #343447
+ # gsc collides with gambit, bug #253064
+ mv -f "${ED}"/usr/bin/{gsc,gs} || die
+
+ cd "${S}/ijs" || die
+ emake DESTDIR="${D}" install
+
+ # Sometimes the upstream versioning deviates from the tarball(!)
+ # bug #844115#c32
+ local my_gs_version=$(find "${ED}"/usr/share/ghostscript/ -maxdepth 1 -mindepth 1 -type d || die)
+ my_gs_version=${my_gs_version##*/}
+
+ # Install the CMaps from poppler-data properly, bug #409361
+ dosym -r /usr/share/poppler/cMaps /usr/share/ghostscript/${my_gs_version}/Resource/CMap
+
+ if ! use static-libs; then
+ find "${ED}" -name '*.la' -delete || die
+ fi
+}