summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-01-05 20:18:31 -0600
committerTim Harder <radhermit@gentoo.org>2019-01-05 20:55:48 -0600
commitab5edda8210892937cd4c45e87c6ec6391b233cf (patch)
treeabf33b53b3629b85b6e1d871d6896020a996d69a /app-vim/fugitive
parentapp-vim/diffchar: remove old (diff)
downloadgentoo-ab5edda8210892937cd4c45e87c6ec6391b233cf.tar.gz
gentoo-ab5edda8210892937cd4c45e87c6ec6391b233cf.tar.bz2
gentoo-ab5edda8210892937cd4c45e87c6ec6391b233cf.zip
app-vim/fugitive: version bump to 2.5
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'app-vim/fugitive')
-rw-r--r--app-vim/fugitive/Manifest1
-rw-r--r--app-vim/fugitive/fugitive-2.5.ebuild22
-rw-r--r--app-vim/fugitive/fugitive-9999.ebuild6
3 files changed, 26 insertions, 3 deletions
diff --git a/app-vim/fugitive/Manifest b/app-vim/fugitive/Manifest
index 377687c55fdf..8dfed86f1778 100644
--- a/app-vim/fugitive/Manifest
+++ b/app-vim/fugitive/Manifest
@@ -1,2 +1,3 @@
DIST fugitive-2.3.tar.gz 30949 BLAKE2B ff62ad9f5b85fff6a06fe006884901ca0f80a5ee139032955a6af596cadf3dca18d73980da12429706102cbe8105fcbff5fb1dd6375b851f978746a5251f1d22 SHA512 8a176705c0326ac034abaf23423e58d490feb7f11dc45ad23641fafb95279094ed38475a90e7c2e7fc95c615558db75f3587740e2658f3988fa07a1957aa1039
DIST fugitive-2.4.tar.gz 33340 BLAKE2B d5e5df47e0492510abae735dd47b51d797fe38862401f7d8e64404f6fa4e040641141c6febb13b05910cc44dc0372b084fe0ee8c3980a73d11d65e1a502ed627 SHA512 fb9d4129090bbafcace9400e9f21feae06bc9f903a54cfef7c4cbfa62856019a511b924c294e86fd26cd713d588ca0054a17d9676b59e2f406779ab5d51c3363
+DIST fugitive-2.5.tar.gz 39318 BLAKE2B 437f4c36b357937fc83e0107882d535c5cc9e609801147d1a48c28e16c4f964c221ff404301e57c9d740a04caf4cf5383a1f307ad89a76294e13b784561223bd SHA512 9a58ff3fa9eae72fca3d1232d01856ef56fe38b7bbf61be44ec4cdf4f0f69fca69fafe19266d657530a6d08f856236b1d1370bb770b14402bb7e476d5ca4bb78
diff --git a/app-vim/fugitive/fugitive-2.5.ebuild b/app-vim/fugitive/fugitive-2.5.ebuild
new file mode 100644
index 000000000000..fe8da7842fc2
--- /dev/null
+++ b/app-vim/fugitive/fugitive-2.5.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit vim-plugin
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/tpope/vim-fugitive.git"
+else
+ SRC_URI="https://github.com/tpope/vim-fugitive/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~ppc-macos ~x64-macos"
+ S="${WORKDIR}/vim-${P}"
+fi
+
+DESCRIPTION="vim plugin: a git wrapper for vim"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=2975 https://github.com/tpope/vim-fugitive/"
+LICENSE="vim"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="dev-vcs/git"
diff --git a/app-vim/fugitive/fugitive-9999.ebuild b/app-vim/fugitive/fugitive-9999.ebuild
index 3ec007ea68be..fe8da7842fc2 100644
--- a/app-vim/fugitive/fugitive-9999.ebuild
+++ b/app-vim/fugitive/fugitive-9999.ebuild
@@ -1,16 +1,16 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit vim-plugin
if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/tpope/vim-fugitive.git"
else
- inherit vcs-snapshot
SRC_URI="https://github.com/tpope/vim-fugitive/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86 ~ppc-macos ~x64-macos"
+ S="${WORKDIR}/vim-${P}"
fi
DESCRIPTION="vim plugin: a git wrapper for vim"