summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ada/gtkada
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ada/gtkada')
-rw-r--r--dev-ada/gtkada/Manifest1
-rw-r--r--dev-ada/gtkada/files/gtkada-2.4.0.patch11
-rw-r--r--dev-ada/gtkada/gtkada-2.10.0.ebuild112
-rw-r--r--dev-ada/gtkada/metadata.xml6
4 files changed, 130 insertions, 0 deletions
diff --git a/dev-ada/gtkada/Manifest b/dev-ada/gtkada/Manifest
new file mode 100644
index 000000000000..89aa53a3a38c
--- /dev/null
+++ b/dev-ada/gtkada/Manifest
@@ -0,0 +1 @@
+DIST GtkAda-gpl-2.10.0.tgz 5519438 SHA256 f5a1a4efecaf99ce7cdaecfa4df7b6935be03692c9b68d8c746a58cca1137a30 SHA512 5162a5c75d5bf9e6f7f6d5f9b54680d7b4fb1265010630d96e9054b9d1993b8f06c63533f6fdbdc6f7b2137c3d88fb7fec06d0ca1460014e701a2469b280d173 WHIRLPOOL 4454e4824b036f6e5072b5d6b042213bbca5ffd27e4c7a6e903f41e0806bc8b232b439fc7480c533c10bab0ac65c40513364c4f266c8f367eda5cdcd76bcefe8
diff --git a/dev-ada/gtkada/files/gtkada-2.4.0.patch b/dev-ada/gtkada/files/gtkada-2.4.0.patch
new file mode 100644
index 000000000000..063507f4a09b
--- /dev/null
+++ b/dev-ada/gtkada/files/gtkada-2.4.0.patch
@@ -0,0 +1,11 @@
+diff -ru GtkAda-2.4.0-orig/src/gtkada-mdi.adb GtkAda-2.4.0/src/gtkada-mdi.adb
+--- GtkAda-2.4.0-orig/src/gtkada-mdi.adb 2004-11-09 09:35:57.000000000 +0100
++++ GtkAda-2.4.0/src/gtkada-mdi.adb 2006-05-18 23:15:13.917488750 +0200
+@@ -4778,6 +4778,7 @@
+ when Top | Bottom =>
+ Widths (Side) := 0;
+ Heights (Side) := Get_Allocation_Height (MDI.Docks (Side));
++ when None => Null;
+ end case;
+
+ -- If not allocated yet
diff --git a/dev-ada/gtkada/gtkada-2.10.0.ebuild b/dev-ada/gtkada/gtkada-2.10.0.ebuild
new file mode 100644
index 000000000000..3688bf2b66a5
--- /dev/null
+++ b/dev-ada/gtkada/gtkada-2.10.0.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils gnat versionator
+
+Name="GtkAda-gpl"
+MajorPV=$(get_version_component_range 1-2)
+DESCRIPTION="Gtk+ bindings to the Ada language"
+HOMEPAGE="https://libre.adacore.com/GtkAda/"
+SRC_URI="mirror://gentoo/${Name}-${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~x86 ~ppc"
+IUSE="nls opengl"
+
+DEPEND="virtual/ada
+ >=x11-libs/cairo-1.2.6
+ >=dev-libs/glib-2.12.4
+ >=x11-libs/pango-1.14.9
+ >=dev-libs/atk-1.12.1
+ >=x11-libs/gtk+-2.10.9
+ >=sys-apps/sed-4"
+RDEPEND=""
+
+S="${WORKDIR}/${Name}-${PV}"
+
+# only needed for gcc-3.x based gnat profiles, but matching them individually
+# would be insane
+QA_EXECSTACK="${AdalibLibTop:1}/*/gtkada/libgtkada-${MajorPV}.so.0"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ sed -i -e "s:-aI\$prefix/include/gtkada:-aI${AdalibSpecsDir}/gtkada:" \
+ src/tools/gtkada-config.in
+
+ # disable building tests to avoid waisting time while building for every
+ # profile. The tests are nonetheless installed under doc dir.
+ sed -i -e "/testgtk_dir/d" Makefile.in
+
+ # remove lib stripping
+ sed -i -e "s: strip \$(LIBNAME)::" src/Makefile.common.in
+}
+
+lib_compile() {
+ # some profile specific fixes first
+ sed -i -e "s:\$prefix/lib\(/gtkada\)*:${AdalibLibTop}/$1/gtkada:" \
+ src/tools/gtkada-config.in
+
+ local myconf
+ use opengl && myconf="--with-GL=auto" || myconf="--with-GL=no"
+
+ econf ${myconf} $(use_enable nls) || die "./configure failed"
+
+ # bug #279962
+ emake -j1 GNATFLAGS="${ADACFLAGS}" || die
+}
+
+lib_install() {
+ # make install misses all the .so and .a files and otherwise creates more
+ # problems than it's worth. Will do everything manually
+ mkdir -p "${DL}"
+ mv src/lib-obj/* src/*/obj/* src/tools/gtkada-config "${DL}"
+ rm "${DL}"/*.o
+ chmod 0444 "${DL}"/*.ali
+ chmod 0755 "${DL}"/gtkada-config
+}
+
+src_install() {
+ #set up environment
+ echo "PATH=%DL%" > ${LibEnv}
+ echo "LDPATH=%DL%" >> ${LibEnv}
+ echo "ADA_OBJECTS_PATH=%DL%" >> ${LibEnv}
+ echo "ADA_INCLUDE_PATH=${AdalibSpecsDir}/${PN}" >> ${LibEnv}
+
+ gnat_src_install
+
+ #specs
+ cd "${S}"/src
+ dodir "${AdalibSpecsDir}/${PN}"
+ insinto "${AdalibSpecsDir}/${PN}"
+ doins *.ad? glade/*.ad? gnome/*.ad? opengl/*.{ad?,c,h}
+
+ #docs
+ cd "${S}"
+ dodoc ANNOUNCE AUTHORS README
+ cp -dPr examples/ testgtk/ "${D}/usr/share/doc/${PF}"
+ cd "${S}"/docs
+ doinfo gtkada_ug/gtkada_ug.info
+ ps2pdf gtkada_ug/gtkada_ug.ps
+ ps2pdf gtkada_rm/gtkada_rm.ps
+ cp gtkada_ug.pdf gtkada_rm.pdf "${D}/usr/share/doc/${PF}"
+ dohtml -r gtkada_ug/{gtkada_ug.html,boxes.gif,hierarchy.jpg}
+ cp -dPr gtkada_rm/gtkada_rm/ "${D}/usr/share/doc/${PF}/html"
+
+ # utility stuff
+ cd "${S}"
+ dodir "${AdalibDataDir}/${PN}"
+ insinto "${AdalibDataDir}/${PN}"
+ doins -r xml/gtkada.xml projects/
+}
+
+pkg_postinst() {
+ eselect gnat update
+ einfo "The environment has been set up to make gnat automatically find files for"
+ einfo "GtkAda. In order to immediately activate these settings please do:"
+ einfo " env-update && source /etc/profile"
+ einfo "Otherwise the settings will become active next time you login"
+}
diff --git a/dev-ada/gtkada/metadata.xml b/dev-ada/gtkada/metadata.xml
new file mode 100644
index 000000000000..bc1d9dd433a6
--- /dev/null
+++ b/dev-ada/gtkada/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ada</herd>
+<longdescription>GtkAda is the technology that lets you implement the next generation of Ada 95 GUIs in an efficient and platform-independent manner. In addition to providing over 100 widgets and allowing you to use portable low-level drawing primitives, GtkAda has a pluggable look-and-feel and comes with a high-level GUI builder that allows round-trip GUI generation and update.</longdescription>
+</pkgmetadata>