summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-19 03:01:56 +0000
committerSam James <sam@gentoo.org>2022-11-19 03:19:14 +0000
commitb4f9cf849e54166305b1f167261bad7c9728da2f (patch)
tree5d6dd9a5153b5b505e7f9323be2ec2f2ec153b47 /dev-cpp/elfio/elfio-3.11.ebuild
parentdev-cpp/tbb: backport pthread EAGAIN patch for mold (diff)
downloadgentoo-b4f9cf849e54166305b1f167261bad7c9728da2f.tar.gz
gentoo-b4f9cf849e54166305b1f167261bad7c9728da2f.tar.bz2
gentoo-b4f9cf849e54166305b1f167261bad7c9728da2f.zip
dev-cpp/elfio: add 3.11
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp/elfio/elfio-3.11.ebuild')
-rw-r--r--dev-cpp/elfio/elfio-3.11.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-cpp/elfio/elfio-3.11.ebuild b/dev-cpp/elfio/elfio-3.11.ebuild
new file mode 100644
index 000000000000..0c82a247cdd9
--- /dev/null
+++ b/dev-cpp/elfio/elfio-3.11.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="ELF reader/producer header-only C++ library"
+HOMEPAGE="https://github.com/serge1/ELFIO"
+SRC_URI="https://github.com/serge1/${PN}/archive/Release_${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN^^}-Release_${PV}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-cpp/gtest )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.11-system-gtest.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DFETCHCONTENT_FULLY_DISCONNECTED=ON
+ -DELFIO_BUILD_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}