summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2023-11-01 10:42:39 +0000
committerPatrick Lauer <patrick@gentoo.org>2023-11-01 10:42:39 +0000
commit15110e66fcd2bd2cde4c70e4f753a9994a1aab8f (patch)
treeba0563e453a64bc4efced3b4ea39ead70ec55e0d /dev-db/barman/barman-3.9.0.ebuild
parentmedia-sound/vorbis-tools: Fix install dir for ogg123 example (diff)
downloadgentoo-15110e66fcd2bd2cde4c70e4f753a9994a1aab8f.tar.gz
gentoo-15110e66fcd2bd2cde4c70e4f753a9994a1aab8f.tar.bz2
gentoo-15110e66fcd2bd2cde4c70e4f753a9994a1aab8f.zip
dev-db/barman: add 3.9.0
Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'dev-db/barman/barman-3.9.0.ebuild')
-rw-r--r--dev-db/barman/barman-3.9.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-db/barman/barman-3.9.0.ebuild b/dev-db/barman/barman-3.9.0.ebuild
new file mode 100644
index 000000000000..1c3e0f925562
--- /dev/null
+++ b/dev-db/barman/barman-3.9.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517="setuptools"
+PYTHON_COMPAT=( python3_{10..11} )
+
+RESTRICT="test" # missing azure sdk
+
+inherit distutils-r1
+
+DESCRIPTION="Administration tool for disaster recovery of PostgreSQL servers"
+HOMEPAGE="https://www.pgbarman.org https://sourceforge.net/projects/pgbarman/"
+SRC_URI="https://github.com/2ndquadrant-it/barman/archive/release/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-release-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/boto3[${PYTHON_USEDEP}]
+ dev-python/argh[${PYTHON_USEDEP}]
+ dev-python/psycopg:2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/argcomplete[${PYTHON_USEDEP}]
+ net-misc/rsync
+ dev-db/postgresql[server]
+"
+
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/python-snappy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ default
+
+ sed -i -e \
+ "s/^ def test_xlog_segment_mask(.*:/ @pytest.mark.xfail(reason='Test fails on Gentoo')\n\0/" \
+ tests/test_xlog.py || die
+}