summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-27 14:50:55 +0100
committerSam James <sam@gentoo.org>2023-03-27 14:51:08 +0100
commitfae8773de0a78fd9b311c09d38ee0bea2a854630 (patch)
tree156541c137d83b0e1542adfb39c1d3ecacd5d12d /dev-db/mariadb
parentnet-libs/nghttp3: drop 0.8.0-r1, 0.9.0 (diff)
downloadgentoo-fae8773de0a78fd9b311c09d38ee0bea2a854630.tar.gz
gentoo-fae8773de0a78fd9b311c09d38ee0bea2a854630.tar.bz2
gentoo-fae8773de0a78fd9b311c09d38ee0bea2a854630.zip
dev-db/mariadb: fix build w/ gcc-13
Closes: https://bugs.gentoo.org/895698 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-db/mariadb')
-rw-r--r--dev-db/mariadb/files/mariadb-10.5.17-gcc-13.patch23
-rw-r--r--dev-db/mariadb/mariadb-10.5.19-r1.ebuild1
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-db/mariadb/files/mariadb-10.5.17-gcc-13.patch b/dev-db/mariadb/files/mariadb-10.5.17-gcc-13.patch
new file mode 100644
index 000000000000..c474028e7e06
--- /dev/null
+++ b/dev-db/mariadb/files/mariadb-10.5.17-gcc-13.patch
@@ -0,0 +1,23 @@
+https://bugs.gentoo.org/895698
+https://github.com/MariaDB/server/commit/75bbf645a66db797be2abd3a348dce32eb753acc
+
+From 75bbf645a66db797be2abd3a348dce32eb753acc Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Tue, 24 Jan 2023 21:40:43 -0800
+Subject: [PATCH] Add missing include <cstdio>
+
+This is needed with GCC 13 and newer [1]
+
+[1] https://www.gnu.org/software/gcc/gcc-13/porting_to.html
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+--- a/tpool/aio_linux.cc
++++ b/tpool/aio_linux.cc
+@@ -19,6 +19,7 @@ Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02111 - 1301 USA*/
+ #ifdef LINUX_NATIVE_AIO
+ # include <thread>
+ # include <atomic>
++# include <cstdio>
+ # include <libaio.h>
+ # include <sys/syscall.h>
+
diff --git a/dev-db/mariadb/mariadb-10.5.19-r1.ebuild b/dev-db/mariadb/mariadb-10.5.19-r1.ebuild
index 23642e369303..16de54792e38 100644
--- a/dev-db/mariadb/mariadb-10.5.19-r1.ebuild
+++ b/dev-db/mariadb/mariadb-10.5.19-r1.ebuild
@@ -213,6 +213,7 @@ src_prepare() {
eapply "${WORKDIR}"/mariadb-patches
eapply "${FILESDIR}"/${PN}-10.6.11-gssapi.patch
eapply "${FILESDIR}"/${PN}-10.6.12-gcc-13.patch
+ eapply "${FILESDIR}"/${PN}-10.5.17-gcc-13.patch
eapply_user