summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2015-12-15 16:39:51 -0500
committerAaron W. Swenson <titanofold@gentoo.org>2015-12-15 16:39:51 -0500
commit17eb751adda1ed29ae00e12e47199b09ff7f4673 (patch)
tree41ae7829ee73df1d236dba60ccfd535a5e0c821f /dev-db/postgresql/postgresql-9999.ebuild
parentgames-server/crossfire-server: Fix format security. Bug #544352 (diff)
downloadgentoo-17eb751adda1ed29ae00e12e47199b09ff7f4673.tar.gz
gentoo-17eb751adda1ed29ae00e12e47199b09ff7f4673.tar.bz2
gentoo-17eb751adda1ed29ae00e12e47199b09ff7f4673.zip
dev-db/postgresql: Hardcode install
Rely on $PATH being in the proper order so that the correct install program is used for modules utilizing PGXS in both hardened and non-hardened environments. Bug: 528786 Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-db/postgresql/postgresql-9999.ebuild')
-rw-r--r--dev-db/postgresql/postgresql-9999.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-db/postgresql/postgresql-9999.ebuild b/dev-db/postgresql/postgresql-9999.ebuild
index c2fe866097b0..addb7aa53fc9 100644
--- a/dev-db/postgresql/postgresql-9999.ebuild
+++ b/dev-db/postgresql/postgresql-9999.ebuild
@@ -112,6 +112,11 @@ src_prepare() {
sed "s|\(PGSOCKET_DIR\s\+\)\"/tmp\"|\1\"${EPREFIX}/run/postgresql\"|" \
-i src/include/pg_config_manual.h || die
+ # Rely on $PATH being in the proper order so that the correct
+ # install program is used for modules utilizing PGXS in both
+ # hardened and non-hardened environments. (Bug #528786)
+ sed 's/@install_bin@/install -c/' -i src/Makefile.global.in || die
+
if use pam ; then
sed -e "s/\(#define PGSQL_PAM_SERVICE \"postgresql\)/\1-${SLOT}/" \
-i src/backend/libpq/auth.c || \