summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-05-11 03:32:01 +0100
committerSam James <sam@gentoo.org>2024-05-11 03:32:01 +0100
commit433856b93366defbd2ef42e55bf474c6d7f25ecf (patch)
treefc6a0c214042e72c413abcb9011fe2059996f7af /dev-db/postgresql/postgresql-9999.ebuild
parentsys-libs/readline: drop 8.1_p2-r1 (diff)
downloadgentoo-433856b93366defbd2ef42e55bf474c6d7f25ecf.tar.gz
gentoo-433856b93366defbd2ef42e55bf474c6d7f25ecf.tar.bz2
gentoo-433856b93366defbd2ef42e55bf474c6d7f25ecf.zip
dev-db/postgresql: drop old Perl workaround
The code being removed here can't work with modern Perl: ``` $ perl -e 'use utf8; use re; package utf8; require "utf8_heavy.pl";'; Can't locate utf8_heavy.pl in @INC (@INC entries checked: /etc/perl /usr/local/lib64/perl5/5.38/x86_64-linux /usr/local/lib64/perl5/5.38 /usr/lib64/perl5/vendor_perl/5.38/x86_64-linux /usr/lib64/perl5/vendor_perl/5.38 /usr/lib64/perl5/5.38/x86_64-linux /usr/lib64/perl5/5.38) at -e line 1. ``` The original reporter of the bug it was added for (bug #518522) was Chris Mayo who can't reproduce the original problem. Given it now actively causes an issue, let's drop it, and not worry about replacing it with something else right now - it's unclear anything is needed now. This still leaves pollution in postgresql.conf - which I leave to the pgsql maintainers to resolve, but at least we're not adding it for new installs now. Note that it's likely https://bugs.gentoo.org/518522#c6 was still an issue and this will be resolved now too. Bug: https://bugs.gentoo.org/518522 Bug: https://bugs.gentoo.org/792537 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-db/postgresql/postgresql-9999.ebuild')
-rw-r--r--dev-db/postgresql/postgresql-9999.ebuild7
1 files changed, 0 insertions, 7 deletions
diff --git a/dev-db/postgresql/postgresql-9999.ebuild b/dev-db/postgresql/postgresql-9999.ebuild
index 1fa775af92f2..7933efb78c75 100644
--- a/dev-db/postgresql/postgresql-9999.ebuild
+++ b/dev-db/postgresql/postgresql-9999.ebuild
@@ -388,13 +388,6 @@ pkg_config() {
# overridden in the initscript
sed '/^#unix_socket_directories/,+1d' -i "${PGDATA%/}"/postgresql.conf
- cat <<- EOF >> "${PGDATA%/}"/postgresql.conf
- # This is here because of https://bugs.gentoo.org/show_bug.cgi?id=518522
- # On the off-chance that you might need to work with UTF-8 encoded
- # characters in PL/Perl
- plperl.on_init = 'use utf8; use re; package utf8; require "utf8_heavy.pl";'
- EOF
-
einfo "The autovacuum function, which was in contrib, has been moved to the main"
einfo "PostgreSQL functions starting with 8.1, and starting with 8.4 is now enabled"
einfo "by default. You can disable it in the cluster's:"