summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-11-17 05:17:58 +0000
committerSam James <sam@gentoo.org>2024-11-17 05:17:58 +0000
commitb61b5fa9f4c8d0351d94c0fd29298e4d142855fe (patch)
tree7427f513e3933ae680b64fb788183b2b4a62155c /dev-db/postgresql/postgresql-9999.ebuild
parentsys-libs/ncurses: add 6.5_p20241109 (diff)
downloadgentoo-b61b5fa9f4c8d0351d94c0fd29298e4d142855fe.tar.gz
gentoo-b61b5fa9f4c8d0351d94c0fd29298e4d142855fe.tar.bz2
gentoo-b61b5fa9f4c8d0351d94c0fd29298e4d142855fe.zip
dev-db/postgresql: build w/ -std=gnu17
Upcoming GCC 15 defaults to -std=gnu23 which pg fails to build with. Go back to the default -std=gnu17 (i.e. a noop for older GCCs) until the upstream report I've sent is fixed. Sent that to pgsql-bugs but it's still in the moderation queue for now, I'll update with the link once it's through. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-db/postgresql/postgresql-9999.ebuild')
-rw-r--r--dev-db/postgresql/postgresql-9999.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-db/postgresql/postgresql-9999.ebuild b/dev-db/postgresql/postgresql-9999.ebuild
index b6efc09b8671..6f69a27051a3 100644
--- a/dev-db/postgresql/postgresql-9999.ebuild
+++ b/dev-db/postgresql/postgresql-9999.ebuild
@@ -143,6 +143,11 @@ src_prepare() {
}
src_configure() {
+ # Fails to build with C23, fallback to the old default in < GCC 15
+ # for now. Reported upstream to pgsql-bugs ML but not yet through
+ # moderation filter.
+ append-cflags -std=gnu17
+
case ${CHOST} in
*-darwin*|*-solaris*)
use nls && append-libs intl