summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-db/tora
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-db/tora')
-rw-r--r--dev-db/tora/Manifest1
-rw-r--r--dev-db/tora/metadata.xml22
-rw-r--r--dev-db/tora/tora-3.0.0_pre20140929-r1.ebuild86
-rw-r--r--dev-db/tora/tora-9999.ebuild90
4 files changed, 199 insertions, 0 deletions
diff --git a/dev-db/tora/Manifest b/dev-db/tora/Manifest
new file mode 100644
index 000000000000..a8c359e466b1
--- /dev/null
+++ b/dev-db/tora/Manifest
@@ -0,0 +1 @@
+DIST tora-3.0.0_pre20140929.tar.xz 9038680 SHA256 67fb6273c930b4ba4cbc185fd3e2a68b8c7029098b14f729ffbdfa09ed91af2b SHA512 42bc76d8bbed8a5cfee447ea6dec9966a31ef740d3ab58078ecdfc12f725cc94568fbb96d044668ae5fd83def5ab35823df6dee77b630e7903edfd1521b87b73 WHIRLPOOL 7fcf7fbe06d1fa4d31a88674f011c634ec9ef12003a074c8185a981650fff8aef85725007f51a3e463d95f332fde724392fd748d4fdbc464663a2da3b8ec8693
diff --git a/dev-db/tora/metadata.xml b/dev-db/tora/metadata.xml
new file mode 100644
index 000000000000..9155cc041873
--- /dev/null
+++ b/dev-db/tora/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>ikonta@yandex.ru</email>
+ <name>Sergey Starikoff</name>
+ </maintainer>
+ <maintainer>
+ <email>haubi@gentoo.org</email>
+ <name>Michael Haubenwallner</name>
+ </maintainer>
+ <longdescription>
+ TOra is a Toolkit for Oracle which aims to help the DBA or developer of
+ database application. Features PL/SQL debugger, SQL worksheet with syntax
+ highlighting, DB browser and a comprehensive set of DBA tools. Also works
+ with mySQL and postgreSQL.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">tora</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-db/tora/tora-3.0.0_pre20140929-r1.ebuild b/dev-db/tora/tora-3.0.0_pre20140929-r1.ebuild
new file mode 100644
index 000000000000..d7a74799d1f2
--- /dev/null
+++ b/dev-db/tora/tora-3.0.0_pre20140929-r1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils eutils
+
+if [[ ${PV} == 9999 ]]; then
+ ESVN_REPO_URI="https://tora.svn.sourceforge.net/svnroot/tora/trunk/tora"
+ inherit subversion
+ SRC_URI=""
+else
+ SRC_URI="http://dev.gentoo.org/~pinkbyte/distfiles/snapshots/${P}.tar.xz"
+fi
+
+DESCRIPTION="TOra - Toolkit For Oracle"
+HOMEPAGE="http://torasql.com/"
+IUSE="debug mysql postgres"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/ferrisloki
+ x11-libs/qscintilla
+ dev-qt/qtgui:4
+ dev-qt/qtsql:4[mysql?,postgres?]
+ dev-qt/qtxmlpatterns:4
+ =dev-db/oracle-instantclient-basic-11*
+ postgres? ( dev-db/postgresql )
+"
+
+DEPEND="
+ virtual/pkgconfig
+ ${RDEPEND}
+"
+
+pkg_setup() {
+ if [ -z "$ORACLE_HOME" ] ; then
+ eerror "ORACLE_HOME variable is not set."
+ eerror
+ eerror "You must install Oracle >= 8i client for Linux in"
+ eerror "order to compile TOra with Oracle support."
+ eerror
+ eerror "You can download the Oracle software from"
+ eerror "http://otn.oracle.com/software/content.html"
+ die
+ fi
+}
+
+src_prepare() {
+ sed -i \
+ -e "/COPYING/ d" \
+ CMakeLists.txt || die "Removal of COPYING file failed"
+ # bug 547520
+ grep -rlZ '$$ORIGIN' . | xargs -0 sed -i 's|:$$ORIGIN[^:"]*||' || \
+ die 'Removal of $$ORIGIN failed'
+}
+
+src_configure() {
+ local mycmakeargs=()
+ mycmakeargs=(-DENABLE_ORACLE=ON)
+ mycmakeargs+=(
+ -DWANT_RPM=OFF
+ -DWANT_BUNDLE=OFF
+ -DWANT_BUNDLE_STANDALONE=OFF
+ -DWANT_INTERNAL_QSCINTILLA=OFF
+ -DWANT_INTERNAL_LOKI=OFF
+ -DLOKI_LIBRARY="$(pkg-config --variable=libdir ferrisloki)/libferrisloki.so"
+ -DLOKI_INCLUDE_DIR="$(pkg-config --variable=includedir ferrisloki)/FerrisLoki"
+ $(cmake-utils_use_enable postgres PGSQL)
+ $(cmake-utils_use_want debug)
+ # path variables
+ -DTORA_DOC_DIR=share/doc/${PF}
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ #
+ doicon src/icons/${PN}.xpm || die
+ domenu src/${PN}.desktop || die
+}
diff --git a/dev-db/tora/tora-9999.ebuild b/dev-db/tora/tora-9999.ebuild
new file mode 100644
index 000000000000..80e45b5a8159
--- /dev/null
+++ b/dev-db/tora/tora-9999.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils eutils
+
+if [[ ${PV} == 9999 ]]; then
+ ESVN_REPO_URI="https://tora.svn.sourceforge.net/svnroot/tora/trunk/tora"
+ inherit subversion
+ SRC_URI=""
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="TOra - Toolkit For Oracle"
+HOMEPAGE="http://torasql.com/"
+IUSE="debug mysql oracle oci8-instant-client postgres"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS=""
+
+DEPEND="
+ virtual/pkgconfig
+ dev-libs/ferrisloki
+ x11-libs/qscintilla
+ dev-qt/qtgui:4
+ dev-qt/qtsql:4[mysql?,postgres?]
+ dev-qt/qtxmlpatterns:4
+ oci8-instant-client? ( dev-db/oracle-instantclient-basic )
+ postgres? ( dev-db/postgresql )
+"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if ( use oracle || use oci8-instant-client ) && [ -z "$ORACLE_HOME" ] ; then
+ eerror "ORACLE_HOME variable is not set."
+ eerror
+ eerror "You must install Oracle >= 8i client for Linux in"
+ eerror "order to compile TOra with Oracle support."
+ eerror
+ eerror "Otherwise specify -oracle in your USE variable."
+ eerror
+ eerror "You can download the Oracle software from"
+ eerror "http://otn.oracle.com/software/content.html"
+ die
+ fi
+}
+
+src_prepare() {
+ sed -i \
+ -e "/COPYING/ d" \
+ CMakeLists.txt || die "Removal of COPYING file failed"
+ # 'svn info' needs .svn subdirectory
+ [[ ${PV} != 9999 ]] || cp -a "${ESVN_WC_PATH}"/.svn .svn || die
+ # bug 547520
+ grep -rlZ '$$ORIGIN' . | xargs -0 sed -i 's|:$$ORIGIN[^:"]*||' || \
+ die 'Removal of $$ORIGIN failed'
+}
+
+src_configure() {
+ local mycmakeargs=()
+ if use oracle || use oci8-instant-client ; then
+ mycmakeargs=(-DENABLE_ORACLE=ON)
+ else
+ mycmakeargs=(-DENABLE_ORACLE=OFF)
+ fi
+ mycmakeargs+=(
+ -DWANT_RPM=OFF
+ -DWANT_BUNDLE=OFF
+ -DWANT_BUNDLE_STANDALONE=OFF
+ -DWANT_INTERNAL_QSCINTILLA=OFF
+ -DWANT_INTERNAL_LOKI=OFF
+ -DLOKI_LIBRARY="$(pkg-config --variable=libdir ferrisloki)/libferrisloki.so"
+ -DLOKI_INCLUDE_DIR="$(pkg-config --variable=includedir ferrisloki)/FerrisLoki"
+ $(cmake-utils_use_enable postgres PGSQL)
+ $(cmake-utils_use_want debug)
+ # path variables
+ -DTORA_DOC_DIR=share/doc/${PF}
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ doicon src/icons/${PN}.xpm
+ domenu src/${PN}.desktop
+}