summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2024-08-11 15:59:38 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-08-11 16:22:09 +0200
commit4d94e03134ab8425dfccdd89e6b070c769c88176 (patch)
treee08ec22222dfe6147c5760765661d10f6175c717 /dev-db
parentdev-libs/intel-vc-intrinsics: add LLVM18 support (diff)
downloadgentoo-4d94e03134ab8425dfccdd89e6b070c769c88176.tar.gz
gentoo-4d94e03134ab8425dfccdd89e6b070c769c88176.tar.bz2
gentoo-4d94e03134ab8425dfccdd89e6b070c769c88176.zip
dev-db/mysqltuner: add 2.6.0
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/mysqltuner/Manifest1
-rw-r--r--dev-db/mysqltuner/mysqltuner-2.6.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-db/mysqltuner/Manifest b/dev-db/mysqltuner/Manifest
index 6f2a4fd61356..130533822121 100644
--- a/dev-db/mysqltuner/Manifest
+++ b/dev-db/mysqltuner/Manifest
@@ -1 +1,2 @@
DIST mysqltuner-2.5.2.tar.gz 5132683 BLAKE2B 439559c05ed9daad6f21fc90f91b3b39619ca2012a719eca3ba4b5d8cb2d963fb8bc10b0ea2855052ca5716fc98aa62f35bd0288380dceb79c1832150fe7f2a8 SHA512 9fe3d77636e3779ca2ab5f93cd7c480d651f6c26f4e6271adfcee6012aa423579f124ce6858bbf7142b2967f30bc0f0517b5d82ad2a35ecc004b1b621d0bee45
+DIST mysqltuner-2.6.0.tar.gz 5137050 BLAKE2B 37f94b71fc8523ab36ed7a6f39a73f1f831bd551d4935ad87b3d20a9894f86551dcf600e806947e62e3cce154658212e39349ed4a83aaec76ad06e3367d6d6d8 SHA512 0ba8b5a8fd952b961d8b8a13f9339925d106abc27d5f9f32c892c268bfbf3742ed6a516b10ef3a64d123c78d0ce6e37a708911487375d06fa7fe91acfe833e0b
diff --git a/dev-db/mysqltuner/mysqltuner-2.6.0.ebuild b/dev-db/mysqltuner/mysqltuner-2.6.0.ebuild
new file mode 100644
index 000000000000..b1b47ccba813
--- /dev/null
+++ b/dev-db/mysqltuner/mysqltuner-2.6.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="MySQLTuner-perl"
+
+DESCRIPTION="Makes recommendations for increased performance and stability for MySQL"
+HOMEPAGE="https://github.com/major/MySQLTuner-perl"
+SRC_URI="https://github.com/major/${MY_PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/perl
+ virtual/perl-Getopt-Long
+"
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ newbin mysqltuner.pl mysqltuner
+ dodoc {CONTRIBUTING,INTERNALS,USAGE}.md
+ einstalldocs
+
+ # Passwords and vulnerabilities are meant to be fed to the script uncompressed.
+ dodoc basic_passwords.txt vulnerabilities.csv
+ docompress -x "/usr/share/doc/${PF}/basic_passwords.txt" "/usr/share/doc/${PF}/vulnerabilities.csv"
+}