summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-03-09 19:40:52 +0100
committerThomas Deutschmann <whissi@gentoo.org>2021-03-09 19:43:34 +0100
commit789d1ea02b91af8fa2de908fbbfd0a7053f766d7 (patch)
treedf5a4dc474ca9e90e49a56ff17c9de9d03bfc823 /dev-db
parentdev-db/mariadb: 10.5.x uses dev-libs/libpcre2 (diff)
downloadgentoo-789d1ea02b91af8fa2de908fbbfd0a7053f766d7.tar.gz
gentoo-789d1ea02b91af8fa2de908fbbfd0a7053f766d7.tar.bz2
gentoo-789d1ea02b91af8fa2de908fbbfd0a7053f766d7.zip
dev-db/mariadb: do not install bundled mytop
Closes: https://bugs.gentoo.org/774945 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/mariadb/mariadb-10.2.37-r1.ebuild (renamed from dev-db/mariadb/mariadb-10.2.37.ebuild)21
-rw-r--r--dev-db/mariadb/mariadb-10.3.28-r1.ebuild (renamed from dev-db/mariadb/mariadb-10.3.28.ebuild)21
-rw-r--r--dev-db/mariadb/mariadb-10.4.18-r1.ebuild (renamed from dev-db/mariadb/mariadb-10.4.18.ebuild)21
-rw-r--r--dev-db/mariadb/mariadb-10.5.9-r1.ebuild21
4 files changed, 40 insertions, 44 deletions
diff --git a/dev-db/mariadb/mariadb-10.2.37.ebuild b/dev-db/mariadb/mariadb-10.2.37-r1.ebuild
index e9b0679e293c..06df5976e16d 100644
--- a/dev-db/mariadb/mariadb-10.2.37.ebuild
+++ b/dev-db/mariadb/mariadb-10.2.37-r1.ebuild
@@ -112,13 +112,6 @@ RDEPEND="selinux? ( sec-policy/selinux-mysql )
!prefix? ( dev-db/mysql-init-scripts acct-group/mysql acct-user/mysql )
extraengine? ( jdbc? ( >=virtual/jre-1.6 ) )
)
- perl? (
- !dev-db/mytop
- virtual/perl-Getopt-Long
- dev-perl/TermReadKey
- virtual/perl-Term-ANSIColor
- virtual/perl-Time-HiRes
- )
"
# For other stuff to bring us in
# dev-perl/DBD-mysql is needed by some scripts installed by MySQL
@@ -696,10 +689,16 @@ src_install() {
doexe "${BUILD_DIR}/extra/my_print_defaults" "${BUILD_DIR}/extra/perror"
fi
- # Remove mytop if perl is not selected
- if [[ -e "${ED}/usr/bin/mytop" ]] && ! use perl ; then
- rm -f "${ED}/usr/bin/mytop" || die
- fi
+ # Remove bundled mytop in favor of dev-db/mytop
+ local mytop_file
+ for mytop_file in \
+ "${ED}/usr/bin/mytop" \
+ "${ED}/usr/share/man/man1/mytop.1" \
+ ; do
+ if [[ -e "${mytop_file}" ]] ; then
+ rm -v "${mytop_file}" || die
+ fi
+ done
# Fix a dangling symlink when galera is not built
if [[ -L "${ED}/usr/bin/wsrep_sst_rsync_wan" ]] && ! use galera ; then
diff --git a/dev-db/mariadb/mariadb-10.3.28.ebuild b/dev-db/mariadb/mariadb-10.3.28-r1.ebuild
index ad9d14ad7a78..803610d155ec 100644
--- a/dev-db/mariadb/mariadb-10.3.28.ebuild
+++ b/dev-db/mariadb/mariadb-10.3.28-r1.ebuild
@@ -111,13 +111,6 @@ RDEPEND="selinux? ( sec-policy/selinux-mysql )
!prefix? ( dev-db/mysql-init-scripts acct-group/mysql acct-user/mysql )
extraengine? ( jdbc? ( >=virtual/jre-1.6 ) )
)
- perl? (
- !dev-db/mytop
- virtual/perl-Getopt-Long
- dev-perl/TermReadKey
- virtual/perl-Term-ANSIColor
- virtual/perl-Time-HiRes
- )
"
# For other stuff to bring us in
# dev-perl/DBD-mysql is needed by some scripts installed by MySQL
@@ -685,10 +678,16 @@ src_install() {
doexe "${BUILD_DIR}/extra/my_print_defaults" "${BUILD_DIR}/extra/perror"
fi
- # Remove mytop if perl is not selected
- if [[ -e "${ED}/usr/bin/mytop" ]] && ! use perl ; then
- rm -f "${ED}/usr/bin/mytop" || die
- fi
+ # Remove bundled mytop in favor of dev-db/mytop
+ local mytop_file
+ for mytop_file in \
+ "${ED}/usr/bin/mytop" \
+ "${ED}/usr/share/man/man1/mytop.1" \
+ ; do
+ if [[ -e "${mytop_file}" ]] ; then
+ rm -v "${mytop_file}" || die
+ fi
+ done
# Fix a dangling symlink when galera is not built
if [[ -L "${ED}/usr/bin/wsrep_sst_rsync_wan" ]] && ! use galera ; then
diff --git a/dev-db/mariadb/mariadb-10.4.18.ebuild b/dev-db/mariadb/mariadb-10.4.18-r1.ebuild
index b18ff61ae8b6..3df4ab74bea7 100644
--- a/dev-db/mariadb/mariadb-10.4.18.ebuild
+++ b/dev-db/mariadb/mariadb-10.4.18-r1.ebuild
@@ -112,13 +112,6 @@ RDEPEND="selinux? ( sec-policy/selinux-mysql )
!prefix? ( dev-db/mysql-init-scripts acct-group/mysql acct-user/mysql )
extraengine? ( jdbc? ( >=virtual/jre-1.6 ) )
)
- perl? (
- !dev-db/mytop
- virtual/perl-Getopt-Long
- dev-perl/TermReadKey
- virtual/perl-Term-ANSIColor
- virtual/perl-Time-HiRes
- )
"
# For other stuff to bring us in
# dev-perl/DBD-mysql is needed by some scripts installed by MySQL
@@ -704,10 +697,16 @@ src_install() {
fi
fi
- # Remove mytop if perl is not selected
- if [[ -e "${ED}/usr/bin/mytop" ]] && ! use perl ; then
- rm -f "${ED}/usr/bin/mytop" || die
- fi
+ # Remove bundled mytop in favor of dev-db/mytop
+ local mytop_file
+ for mytop_file in \
+ "${ED}/usr/bin/mytop" \
+ "${ED}/usr/share/man/man1/mytop.1" \
+ ; do
+ if [[ -e "${mytop_file}" ]] ; then
+ rm -v "${mytop_file}" || die
+ fi
+ done
# Fix a dangling symlink when galera is not built
if [[ -L "${ED}/usr/bin/wsrep_sst_rsync_wan" ]] && ! use galera ; then
diff --git a/dev-db/mariadb/mariadb-10.5.9-r1.ebuild b/dev-db/mariadb/mariadb-10.5.9-r1.ebuild
index 1b714d5bbb04..489bf9437b80 100644
--- a/dev-db/mariadb/mariadb-10.5.9-r1.ebuild
+++ b/dev-db/mariadb/mariadb-10.5.9-r1.ebuild
@@ -120,13 +120,6 @@ RDEPEND="${COMMON_DEPEND}
)
!prefix? ( dev-db/mysql-init-scripts acct-group/mysql acct-user/mysql )
)
- perl? (
- !dev-db/mytop
- virtual/perl-Getopt-Long
- dev-perl/TermReadKey
- virtual/perl-Term-ANSIColor
- virtual/perl-Time-HiRes
- )
"
# For other stuff to bring us in
# dev-perl/DBD-mysql is needed by some scripts installed by MySQL
@@ -699,10 +692,16 @@ src_install() {
fi
fi
- # Remove mytop if perl is not selected
- if [[ -e "${ED}/usr/bin/mytop" ]] && ! use perl ; then
- rm -f "${ED}/usr/bin/mytop" || die
- fi
+ # Remove bundled mytop in favor of dev-db/mytop
+ local mytop_file
+ for mytop_file in \
+ "${ED}/usr/bin/mytop" \
+ "${ED}/usr/share/man/man1/mytop.1" \
+ ; do
+ if [[ -e "${mytop_file}" ]] ; then
+ rm -v "${mytop_file}" || die
+ fi
+ done
# Fix a dangling symlink when galera is not built
if [[ -L "${ED}/usr/bin/wsrep_sst_rsync_wan" ]] && ! use galera ; then