summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-10-28 08:36:51 +0000
committerSam James <sam@gentoo.org>2024-10-28 08:36:51 +0000
commit8d70df1e88102e5b08c7f090f177ddb35cffdb78 (patch)
tree7392ee1dd3ad2872aa0109451af355a7e458ccca /dev-debug
parentdev-util/cvise: Stabilize 2.10.0 ppc, #942373 (diff)
downloadgentoo-8d70df1e88102e5b08c7f090f177ddb35cffdb78.tar.gz
gentoo-8d70df1e88102e5b08c7f090f177ddb35cffdb78.tar.bz2
gentoo-8d70df1e88102e5b08c7f090f177ddb35cffdb78.zip
dev-debug/valgrind: add 3.24.0_rc1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-debug')
-rw-r--r--dev-debug/valgrind/Manifest2
-rw-r--r--dev-debug/valgrind/valgrind-3.24.0_rc1.ebuild193
2 files changed, 195 insertions, 0 deletions
diff --git a/dev-debug/valgrind/Manifest b/dev-debug/valgrind/Manifest
index 70c9a9d2550e..68a9ef99378d 100644
--- a/dev-debug/valgrind/Manifest
+++ b/dev-debug/valgrind/Manifest
@@ -6,3 +6,5 @@ DIST valgrind-3.23.0-patches-2.tar.xz 15024 BLAKE2B ca7085a6dd38cda9df9437697109
DIST valgrind-3.23.0-patches-3.tar.xz 23084 BLAKE2B 4794143bd80f984d5dc07f792837faa139a4bf8cc6220c7c1e79b85f2c0e6ee579eb5e4220decc264a4e21424683554794d015e10aee20b9e34c16724d64eb58 SHA512 0144142d62552158d90a118591a50412d077d3e79fce333fb6da40aff8acd6c924d15c85f69293d1a189b2ecde66c184cf82c8ba3a134f95c439d50e147e331c
DIST valgrind-3.23.0.tar.bz2 16550038 BLAKE2B 9312761b0531006725f13270984b26c48f71ebe66e355b04410d7c01773c9b78ec21db3259cab398e58b3b68f93f5f074db06efe1f359bd7cf423515576191a4 SHA512 27d038faaaf6154cace2df18c3573291393548ba0738dbb6aba58eab6324c5beaa95fc5f3c0271663ca071baf829b15d806f7e81074f7cf087bef20ea0ed3117
DIST valgrind-3.23.0.tar.bz2.asc 488 BLAKE2B b06781577e3e84e506e56bd4acc7341aecacb6b5898d8f0daab627d24bc70c9c60edad11dc7e3723ac77aa9c7978f1e13af7734e7a37763c720e77ea4ff103a4 SHA512 e10b38c72ed1fb8d79a3fa84ab70c475ec7a15927a578ee6715aa74f9600453f0fb72551053b6c31583321c37dab100bafbf6e689c02a3bc06021f6092b4bc80
+DIST valgrind-3.24.0.RC1.tar.bz2 16676048 BLAKE2B 18455d3eaa05acb6fed0dcbb43f0d196171298533797149c0d440d06fb97f091320595f9d4a71e0ebefcfe04ec59ddd8cc653b034bc35af76ae5ad0a72227ba8 SHA512 d92bcc4acb3c283780cd8553be29f282593e7681b3de6ae374e47bc9c0c98e5603725388972344f1c5a25e66ca278b4baff0e53d5767eccb66cd419ab5be0bee
+DIST valgrind-3.24.0.RC1.tar.bz2.asc 488 BLAKE2B 31f85b98a384ac830fcb7584b108b96979dd0542e3c39063b9849b5dc88ab712eb39b17051662d816cc91f26c41804bc292d14bbb6be27f19a59ff5116e1932d SHA512 02e858642e2fd253d9e323c11dbdecaa55be2213a6a3e5dab8a361ede32e54905114804dbb576ac241f4d1b6bd56d58147b8d1879ec187e201182ae5b8a3d3de
diff --git a/dev-debug/valgrind/valgrind-3.24.0_rc1.ebuild b/dev-debug/valgrind/valgrind-3.24.0_rc1.ebuild
new file mode 100644
index 000000000000..bd5cb983fad2
--- /dev/null
+++ b/dev-debug/valgrind/valgrind-3.24.0_rc1.ebuild
@@ -0,0 +1,193 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# The Valgrind upstream maintainer also maintains it in Fedora and will
+# backport fixes there which haven't yet made it into a release. Keep an eye
+# on it for fixes we should cherry-pick too:
+# https://src.fedoraproject.org/rpms/valgrind/tree/rawhide
+#
+# Also check the ${PV}_STABLE branch upstream for backports.
+
+inherit autotools flag-o-matic toolchain-funcs multilib pax-utils
+
+DESCRIPTION="An open-source memory debugger for GNU/Linux"
+HOMEPAGE="https://valgrind.org"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://sourceware.org/git/${PN}.git"
+ inherit git-r3
+else
+ VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/valgrind.gpg
+ inherit verify-sig
+
+ MY_P="${P/_rc/.RC}"
+ MY_P="${MY_P%%_p*}"
+ VALGRIND_PATCH_TARBALL="${MY_P}-patches-${PV##*_p}"
+ SRC_URI="
+ https://sourceware.org/pub/valgrind/${MY_P}.tar.bz2
+ verify-sig? ( https://sourceware.org/pub/valgrind/${MY_P}.tar.bz2.asc )
+ "
+ # Rollups of backports on ${PV}_STABLE branch upstream.
+ if [[ ${PV} == *_p* ]] ; then
+ SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${VALGRIND_PATCH_TARBALL}.tar.xz"
+ fi
+
+ S="${WORKDIR}"/${MY_P}
+
+ if [[ ${PV} != *_rc* ]] ; then
+ KEYWORDS="-* ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+ fi
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="mpi"
+
+DEPEND="mpi? ( virtual/mpi )"
+RDEPEND="${DEPEND}"
+if [[ ${PV} == 9999 ]] ; then
+ # Needed for man pages
+ BDEPEND+="
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ "
+else
+ BDEPEND+=" verify-sig? ( sec-keys/openpgp-keys-valgrind )"
+fi
+
+PATCHES=(
+ # Respect CFLAGS, LDFLAGS
+ "${FILESDIR}"/${PN}-3.7.0-respect-flags.patch
+ "${FILESDIR}"/${PN}-3.15.0-Build-ldst_multiple-test-with-fno-pie.patch
+ "${FILESDIR}"/${PN}-3.21.0-glibc-2.34-suppressions.patch
+)
+
+QA_CONFIG_IMPL_DECL_SKIP+=(
+ # "checking if gcc accepts nested functions" but clang cannot handle good
+ # errors and reports both "function definition is not allowed here" and
+ # -Wimplicit-function-declaration. bug #900396
+ foo
+)
+
+src_unpack() {
+ if [[ ${PV} == 9999 ]] ; then
+ git-r3_src_unpack
+ elif use verify-sig ; then
+ # Needed for downloaded patch (which is unsigned, which is fine)
+ verify-sig_verify_detached "${DISTDIR}"/${MY_P}.tar.bz2{,.asc}
+ fi
+
+ default
+}
+
+src_prepare() {
+ # Correct hard coded doc location
+ sed -i -e "s:doc/valgrind:doc/${PF}:" docs/Makefile.am || die
+
+ # Don't force multiarch stuff on OSX, bug #306467
+ sed -i -e 's:-arch \(i386\|x86_64\)::g' Makefile.all.am || die
+
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ # upstream doesn't support this, but we don't build with
+ # Sun/Oracle ld, we have a GNU toolchain, so get some things
+ # working the Linux/GNU way
+ find "${S}" -name "Makefile.am" -o -name "Makefile.tool.am" | xargs \
+ sed -i -e 's:-M,/usr/lib/ld/map.noexstk:-z,noexecstack:' || die
+ cp "${S}"/coregrind/link_tool_exe_{linux,solaris}.in
+ fi
+
+ if [[ ${PV} != 9999 && -d "${WORKDIR}"/${VALGRIND_PATCH_TARBALL} ]] ; then
+ PATCHES+=( "${WORKDIR}"/${VALGRIND_PATCH_TARBALL} )
+ fi
+
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ --with-gdbscripts-dir="${EPREFIX}"/usr/share/gdb/auto-load
+ )
+
+ tc-is-lto && myconf+=( --enable-lto )
+
+ # Respect ar, bug #468114
+ tc-export AR
+
+ # -fomit-frame-pointer "Assembler messages: Error: junk `8' after expression"
+ # while compiling insn_sse.c in none/tests/x86
+ # -fstack-protector more undefined references to __guard and __stack_smash_handler
+ # because valgrind doesn't link to glibc (bug #114347)
+ # -fstack-protector-all Fails same way as -fstack-protector/-fstack-protector-strong.
+ # Note: -fstack-protector-explicit is a no-op for Valgrind, no need to strip it
+ # -fstack-protector-strong See -fstack-protector (bug #620402)
+ # -m64 -mx32 for multilib-portage, bug #398825
+ # -fharden-control-flow-redundancy: breaks runtime ('jump to the invalid address stated on the next line')
+ filter-flags -fomit-frame-pointer
+ filter-flags -fstack-protector
+ filter-flags -fstack-protector-all
+ filter-flags -fstack-protector-strong
+ filter-flags -m64 -mx32
+ filter-flags -fsanitize -fsanitize=*
+ filter-flags -fharden-control-flow-redundancy
+ append-cflags $(test-flags-CC -fno-harden-control-flow-redundancy)
+ filter-lto
+
+ if use amd64 || use ppc64; then
+ ! has_multilib_profile && myconf+=("--enable-only64bit")
+ fi
+
+ # Force bitness on darwin, bug #306467
+ use x64-macos && myconf+=("--enable-only64bit")
+
+ # Don't use mpicc unless the user asked for it (bug #258832)
+ if ! use mpi; then
+ myconf+=("--without-mpicc")
+ fi
+
+ econf "${myconf[@]}"
+}
+
+src_test() {
+ # fxsave.o, tronical.o have textrels
+ # -fno-strict-aliasing: https://bugs.kde.org/show_bug.cgi?id=486093
+ emake CFLAGS="${CFLAGS} -fno-strict-aliasing" LDFLAGS="${LDFLAGS} -Wl,-z,notext" check
+}
+
+src_install() {
+ if [[ ${PV} == 9999 ]]; then
+ # TODO: Could do HTML docs too with 'all-docs'
+ emake -C docs man-pages FAQ.txt
+ mv docs/FAQ.txt . || die "Couldn't move FAQ.txt"
+ fi
+
+ default
+
+ dodoc FAQ.txt
+
+ pax-mark m "${ED}"/usr/$(get_libdir)/valgrind/*-*-linux
+
+ # See README_PACKAGERS
+ dostrip -x /usr/libexec/valgrind/vgpreload* /usr/$(get_libdir)/valgrind/*
+
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ # fix install_names on shared libraries, can't turn them into bundles,
+ # as dyld won't load them any more then, bug #306467
+ local l
+ for l in "${ED}"/usr/lib/valgrind/*.so ; do
+ install_name_tool -id "${EPREFIX}"/usr/lib/valgrind/${l##*/} "${l}"
+ done
+ fi
+}
+
+pkg_postinst() {
+ elog "Valgrind will not work if libc (e.g. glibc) does not have debug symbols."
+ elog "To fix this you can add splitdebug to FEATURES in make.conf"
+ elog "and remerge glibc. See:"
+ elog "https://bugs.gentoo.org/214065"
+ elog "https://bugs.gentoo.org/274771"
+ elog "https://bugs.gentoo.org/388703"
+}