summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-02-10 14:12:03 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-02-10 17:24:48 +0100
commitb28abd902a912ed2d283b58e1d61ec489379ef29 (patch)
tree68e524548e26af4da300442d5ea8759f90ffb41a /dev-dotnet
parentdev-dotnet/netcoredbg: drop old 3.0.0.1012 (diff)
downloadgentoo-b28abd902a912ed2d283b58e1d61ec489379ef29.tar.gz
gentoo-b28abd902a912ed2d283b58e1d61ec489379ef29.tar.bz2
gentoo-b28abd902a912ed2d283b58e1d61ec489379ef29.zip
dev-dotnet/netcoredbg: use dotnet-pkg eclass
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/netcoredbg/netcoredbg-3.0.0.1018-r1.ebuild (renamed from dev-dotnet/netcoredbg/netcoredbg-3.0.0.1018.ebuild)49
1 files changed, 14 insertions, 35 deletions
diff --git a/dev-dotnet/netcoredbg/netcoredbg-3.0.0.1018.ebuild b/dev-dotnet/netcoredbg/netcoredbg-3.0.0.1018-r1.ebuild
index aeac34f8ec8e..f273ca2ffe32 100644
--- a/dev-dotnet/netcoredbg/netcoredbg-3.0.0.1018.ebuild
+++ b/dev-dotnet/netcoredbg/netcoredbg-3.0.0.1018-r1.ebuild
@@ -7,7 +7,7 @@ MY_PV="$(ver_cut 1-3)-$(ver_cut 4)"
DOTNET_RUNTIME_V="7.0.14"
CMAKE_IN_SOURCE_BUILD="ON"
-
+DOTNET_PKG_COMPAT="8.0"
NUGETS="
microsoft.codeanalysis.analyzers@1.1.0
microsoft.codeanalysis.common@2.3.0
@@ -128,7 +128,7 @@ system.xml.xpath.xdocument@4.3.0
system.xml.xpath@4.3.0
"
-inherit check-reqs cmake flag-o-matic nuget
+inherit check-reqs dotnet-pkg flag-o-matic cmake
DESCRIPTION="NetCoreDbg is a managed code debugger with MI interface for CoreCLR"
HOMEPAGE="https://github.com/Samsung/netcoredbg/"
@@ -159,15 +159,10 @@ SRC_URI+="
LICENSE="MIT"
SLOT="0/${MY_PV}"
-RDEPEND="
- >=virtual/dotnet-sdk-6.0
-"
-BDEPEND="
- ${RDEPEND}
- dev-dotnet/csharp-gentoodotnetinfo
-"
-
CHECKREQS_DISK_BUILD="1400M"
+DOTNET_PKG_PROJECTS=(
+ src/managed/ManagedPart.csproj # Restore but do not build those projects.
+)
PATCHES=(
"${FILESDIR}/${PN}-3.0.0.1012-compileoptions.patch"
)
@@ -175,10 +170,13 @@ QA_FLAGS_IGNORED=".*/libdbgshim.so"
DOCS=( README.md docs/{interop,stepping}.md )
+pkg_setup() {
+ check-reqs_pkg_setup
+ dotnet-pkg_pkg_setup
+}
+
src_unpack() {
- nuget_link-system-nugets
- nuget_link-nuget-archives
- nuget_unpack-non-nuget-archives
+ dotnet-pkg_src_unpack
if [[ -n "${EGIT_REPO_URI}" ]] ; then
git-r3_src_unpack
@@ -186,35 +184,16 @@ src_unpack() {
}
src_prepare() {
- if [[ -z "${DOTNET_ROOT}" ]] ; then
- die "DOTNET_ROOT is not set"
- fi
+ cmake_src_prepare
- export DOTNET_CLI_TELEMETRY_OPTOUT=1
- export DOTNET_NOLOGO=1
- export DOTNET_SKIP_FIRST_TIME_EXPERIENCE=1
- export MSBUILDDISABLENODEREUSE=1
- export UseSharedCompilation=false
-
- find "${S}" -type f -iname nuget.config -exec rm -v {} + || die
- cat <<-EOF > NuGet.config || die
-<?xml version="1.0" encoding="utf-8"?>
-<configuration>
-<packageSources>
-<clear />
-<add key="nuget" value="${NUGET_PACKAGES}" />
-</packageSources>
-</configuration>
-EOF
+ nuget_writeconfig "$(pwd)/"
cp NuGet.config tools/generrmsg/nuget.xml || die
-
- cmake_src_prepare
}
src_configure() {
INSTALL_PREFIX="/usr/$(get_libdir)/${PN}"
- gentoo-dotnet-info || die
append-cxxflags -fpermissive
+ dotnet-pkg_src_configure
local -a mycmakeargs=(
-DBUILD_MANAGED=1