summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Dummer <martin.dummer@gmx.net>2022-05-16 16:27:45 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-06-03 14:01:19 +0300
commit4ea694cdcb134cc9fa257a1f4f318961433a70da (patch)
tree2ea2bb4adf01380f7a6139dfae79101efeac8a30 /dev-embedded
parentsci-libs/opencascade: allow some exceptions (diff)
downloadgentoo-4ea694cdcb134cc9fa257a1f4f318961433a70da.tar.gz
gentoo-4ea694cdcb134cc9fa257a1f4f318961433a70da.tar.bz2
gentoo-4ea694cdcb134cc9fa257a1f4f318961433a70da.zip
dev-embedded/esptool: version bump to 3.3.1
esptool-3.3.1: according to upstream, this is the last 3.x release Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Martin Dummer <martin.dummer@gmx.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/esptool/Manifest1
-rw-r--r--dev-embedded/esptool/esptool-3.3.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-embedded/esptool/Manifest b/dev-embedded/esptool/Manifest
index 8204e36da092..524c1849b23f 100644
--- a/dev-embedded/esptool/Manifest
+++ b/dev-embedded/esptool/Manifest
@@ -1,2 +1,3 @@
DIST esptool-3.2.tar.gz 7155428 BLAKE2B f81a8b77f1994599c3302915915e225249a5e735accbe47c8936de47564e47a33ae711df47c57e599d980b450dc4d710f819087a97d086b9d0f15a98622c0da4 SHA512 5e67b3a17190e051d7706ee2dbbe855488765a7bfed15b15f5a04022c3fbf19112905ba6a672c37b1bac5501d45d477cfff07c004cd83b2d1a111430992cefc1
+DIST esptool-3.3.1.tar.gz 7261340 BLAKE2B c6ee391dcbc331d9f931bfd969333fc3bfc5628d422d52e2963c9d465f4680dca5debaf17cd2f6aca0db9dcc06563fe775d7d6c15dacdff481c52577c26d4364 SHA512 8da34f7b555513d499141ce403f19c3e77b6944eecde440c757faf3bbf5e915e44ff0bcabf1b2cb7f5fe26caa717bb47104ad808c46feaf1dea254d548048095
DIST esptool-3.3.tar.gz 7259717 BLAKE2B b9952dff9a1884cae5325730056673d96bd442c82cd799196d99fe5287b72bc567d312102779f64c4a526c19bd36d0f742b4e81434de8b4dadf406a19bd3d423 SHA512 1f1a43832ae5487c570e49c97ca18831371f5a4ac0d4b260fa8b7356c7af40b8514722ded630a6c84e3d59f7fba78c9d70b291d1fa581fc25ea37204ded44363
diff --git a/dev-embedded/esptool/esptool-3.3.1.ebuild b/dev-embedded/esptool/esptool-3.3.1.ebuild
new file mode 100644
index 000000000000..922aa7b84829
--- /dev/null
+++ b/dev-embedded/esptool/esptool-3.3.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="Utility to communicate with the ROM bootloader in Espressif ESP8266 and ESP32"
+HOMEPAGE="https://github.com/espressif/esptool"
+SRC_URI="https://github.com/espressif/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/bitstring[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ >=dev-python/ecdsa-0.16.0[${PYTHON_USEDEP}]
+ dev-python/pyserial[${PYTHON_USEDEP}]
+ dev-python/reedsolomon[${PYTHON_USEDEP}]
+ ')
+"
+BDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/wheel[${PYTHON_USEDEP}]
+ ')
+ test? ( $(python_gen_cond_dep '
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/pyelftools[${PYTHON_USEDEP}]
+ ') )
+"
+
+python_test() {
+ "${EPYTHON}" test/test_imagegen.py || die "imagegen test failed with ${EPYTHON}"
+ "${EPYTHON}" test/test_espsecure.py || die "espsecure test failed with ${EPYTHON}"
+ "${EPYTHON}" test/test_espefuse_host.py || die "espefuse_host test failed with ${EPYTHON}"
+ "${EPYTHON}" test/test_merge_bin.py || die "espefuse_host test failed with ${EPYTHON}"
+ # test/test_esptool.py and test/test_espefuse.py need real hardware connected
+}