summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-games/mercator
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-games/mercator')
-rw-r--r--dev-games/mercator/Manifest1
-rw-r--r--dev-games/mercator/mercator-0.3.3.ebuild31
-rw-r--r--dev-games/mercator/metadata.xml25
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-games/mercator/Manifest b/dev-games/mercator/Manifest
new file mode 100644
index 000000000000..e96f327ab610
--- /dev/null
+++ b/dev-games/mercator/Manifest
@@ -0,0 +1 @@
+DIST mercator-0.3.3.tar.gz 436499 SHA256 04c71d780979a2b43835b8b30879b39c4d7688661dab8e2bf7046ef9e7aff1e9 SHA512 d8f0bcec904c77ceaadd11474a4a83ec4d5e5086f0c878b147b00f3fb3ef2ae6596553d2d4548f943aa280672dde938d34f4d231782b10149190f5d8029e039a WHIRLPOOL 4ecfe2dcd04526bf9b29e76524c1c6a457fc302aa98c504148a958c3ef399eb8e9167dbf5ed29dbdedd0dedab85c624269224cb030b938308df23a71d06c5129
diff --git a/dev-games/mercator/mercator-0.3.3.ebuild b/dev-games/mercator/mercator-0.3.3.ebuild
new file mode 100644
index 000000000000..cb63e20f9cda
--- /dev/null
+++ b/dev-games/mercator/mercator-0.3.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="WorldForge library primarily aimed at terrain"
+HOMEPAGE="http://www.worldforge.org/index.php/components/mercator/"
+SRC_URI="mirror://sourceforge/worldforge/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="amd64 x86"
+IUSE="doc"
+SLOT="0"
+
+RDEPEND=">=dev-games/wfmath-1"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+
+src_compile() {
+ default
+ use doc && emake docs
+}
+
+src_install() {
+ default
+ use doc && dohtml -r doc/html/*
+ prune_libtool_files
+}
diff --git a/dev-games/mercator/metadata.xml b/dev-games/mercator/metadata.xml
new file mode 100644
index 000000000000..000ad0149523
--- /dev/null
+++ b/dev-games/mercator/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <longdescription lang="en">
+Mercator is primarily aimed at terrain for multiplayer online games and forms
+one of the WorldForge core libraries. It is intended to be used as a terrain
+library on the client, while a subset of features are useful on the server.
+
+Mercator is designed in such a way that individual tiles can be generated
+on-the-fly from a very small source data set. Each tile uses a fast
+deterministic random number generation to ensure that identical results are
+produced "anytime, anywhere". This enables transmission of terrain across low
+bandwidth links as part of the standard data stream, or server side collision
+detection with the same terrain that the player sees.
+
+The use of tiles means that there is inherently a large degree of gross control
+of the shape of the terrain. Finer control is implemented by allowing geometric
+modifications - for example, a polygonal area might be flattened, or a crater
+could be applied.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">worldforge</remote-id>
+ </upstream>
+</pkgmetadata>