summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2023-12-21 09:45:47 -0500
committerMichael Orlitzky <mjo@gentoo.org>2024-01-22 06:28:57 -0500
commitaec2f6e060706bdb66d37df4d2612e8e4d377823 (patch)
tree5de098c5ee96f48dd27a04797fc2a2923e07dc79 /dev-gap/smallgrp
parentdev-gap/primgrp: new package, add 3.4.4 (diff)
downloadgentoo-aec2f6e060706bdb66d37df4d2612e8e4d377823.tar.gz
gentoo-aec2f6e060706bdb66d37df4d2612e8e4d377823.tar.bz2
gentoo-aec2f6e060706bdb66d37df4d2612e8e4d377823.zip
dev-gap/smallgrp: new package, add 1.5.3
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'dev-gap/smallgrp')
-rw-r--r--dev-gap/smallgrp/Manifest1
-rw-r--r--dev-gap/smallgrp/metadata.xml29
-rw-r--r--dev-gap/smallgrp/smallgrp-1.5.3.ebuild25
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-gap/smallgrp/Manifest b/dev-gap/smallgrp/Manifest
new file mode 100644
index 000000000000..44600f9d1938
--- /dev/null
+++ b/dev-gap/smallgrp/Manifest
@@ -0,0 +1 @@
+DIST SmallGrp-1.5.3.tar.gz 20122081 BLAKE2B 91d016c153a189e0505ab52af8aa10f9f5eba90363c7e47258bc589caa5d0bb57faf2fcba99b0a804b3589fbc3a686a923debd68ab790689c7abe62bfbcb9f1a SHA512 4ba88df20ed71cddb2f72d7b9a74b2262aca318e15ce3232e73f7b995d6372caad23b1390030b64cc3a7fdbae5e215f0a20dcad98a2859197187096b01e5da88
diff --git a/dev-gap/smallgrp/metadata.xml b/dev-gap/smallgrp/metadata.xml
new file mode 100644
index 000000000000..79280f03bc91
--- /dev/null
+++ b/dev-gap/smallgrp/metadata.xml
@@ -0,0 +1,29 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ The SmallGrp package provides the library of groups of certain
+ "small" orders. The groups are sorted by their orders and they are
+ listed up to isomorphism; that is, for each of the available orders
+ a complete and irredundant list of isomorphism type representatives
+ of groups is given.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">gap-packages/smallgrp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-gap/smallgrp/smallgrp-1.5.3.ebuild b/dev-gap/smallgrp/smallgrp-1.5.3.ebuild
new file mode 100644
index 000000000000..087d9333870a
--- /dev/null
+++ b/dev-gap/smallgrp/smallgrp-1.5.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gap-pkg
+
+MY_P="SmallGrp-${PV}"
+DESCRIPTION="The GAP Small Groups Library"
+SLOT="0"
+SRC_URI="https://github.com/gap-packages/smallgrp/releases/download/v${PV}/${MY_P}.tar.gz"
+
+LICENSE="Artistic-2"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-gap/gapdoc"
+gap-pkg_enable_tests
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ # Define the variable here so globbing will work
+ GAP_PKG_EXTRA_INSTALL=( id* small* )
+ gap-pkg_src_install
+}