summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrederic Culot <culot@FreeBSD.org>2018-08-24 13:08:00 +0200
committerMichał Górny <mgorny@gentoo.org>2018-08-25 08:26:35 +0200
commit75e5afb1cceb86fd6712a55d467910c0e466ff2a (patch)
treeaf35c0a29ea10a99006b47493b1c74fd3d3b169b /dev-go/fuzzy/fuzzy-0.0.5.ebuild
parentsys-kernel/ck-sources: genpatches-4.14-72 (diff)
downloadgentoo-75e5afb1cceb86fd6712a55d467910c0e466ff2a.tar.gz
gentoo-75e5afb1cceb86fd6712a55d467910c0e466ff2a.tar.bz2
gentoo-75e5afb1cceb86fd6712a55d467910c0e466ff2a.zip
dev-go/fuzzy: 0.0.5 version bump
Closes: https://bugs.gentoo.org/664466 Closes: https://github.com/gentoo/gentoo/pull/9683
Diffstat (limited to 'dev-go/fuzzy/fuzzy-0.0.5.ebuild')
-rw-r--r--dev-go/fuzzy/fuzzy-0.0.5.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-go/fuzzy/fuzzy-0.0.5.ebuild b/dev-go/fuzzy/fuzzy-0.0.5.ebuild
new file mode 100644
index 000000000000..f3a87065a16c
--- /dev/null
+++ b/dev-go/fuzzy/fuzzy-0.0.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN=github.com/sahilm/fuzzy
+
+inherit golang-build golang-vcs-snapshot
+
+DESCRIPTION="Go library that provides fuzzy string matching"
+HOMEPAGE="https://github.com/sahilm/fuzzy"
+SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PVR}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="test? ( dev-go/godebug-pretty )"
+
+src_install() {
+ golang-build_src_install
+
+ pushd "src/${EGO_PN}" >/dev/null || die
+ einstalldocs
+ popd >/dev/null || die
+}