summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <Marek.Szuba@cern.ch>2016-04-21 11:57:19 +0200
committerAnthony G. Basile <blueness@gentoo.org>2016-04-23 02:49:46 -0400
commit81b6ce6c6fc4b2e7d5f04973e144a9704fcf04e5 (patch)
tree3b63ce26c2ac0f3294f718766a1ad9ccda6eb271 /dev-go/siphash
parentsys-fs/hfsplusutils: add support for USE=static-libs (diff)
downloadgentoo-81b6ce6c6fc4b2e7d5f04973e144a9704fcf04e5.tar.gz
gentoo-81b6ce6c6fc4b2e7d5f04973e144a9704fcf04e5.tar.bz2
gentoo-81b6ce6c6fc4b2e7d5f04973e144a9704fcf04e5.zip
New ebuild: net-proxy/obfs4proxy, plus dependencies.
A new obfuscating proxy for Tor bridges which supports, among others, the OBFS4 protocol. It depends on three packages which were not in Portage and therefore have just had ebuild files created as well: dev-go/ed25519, dev-go/goptlib, and dev-go/siphash. Relevant Gentoo bugs: #580582, #580622, #580626, #580628.
Diffstat (limited to 'dev-go/siphash')
-rw-r--r--dev-go/siphash/Manifest3
-rw-r--r--dev-go/siphash/metadata.xml13
-rw-r--r--dev-go/siphash/siphash-1.0.0.ebuild24
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-go/siphash/Manifest b/dev-go/siphash/Manifest
new file mode 100644
index 000000000000..1ae873fa2309
--- /dev/null
+++ b/dev-go/siphash/Manifest
@@ -0,0 +1,3 @@
+DIST siphash-1.0.0.tar.gz 4462 SHA256 0a0526e1a09908e18578b6f3464833e03218f2f2a742de58132f29b6622e339b SHA512 e52dc9857974ab362f2d7b2f7389644fbc07e7bb5507a93f138b3f692c1065303846611bb51b3d9c637d851a4d20cc20af146719a553801a8f7e17ec900a736a WHIRLPOOL 64296af93b1520a32217f9e82c41ae02f15d211bd35f78b77b8246ae83e1825ce31bc1cac3ee831a1e2d5194792f391f7495c07146113975e17e9a13a120825b
+EBUILD siphash-1.0.0.ebuild 493 SHA256 5766a3148a9736643587014d002f1c6576b233061e7720ce75cebd798e8780d2 SHA512 2c68c85ba01f307c6dcbcd6905dc48cfe79ee488c298acfd27db12376eb1b509e4922773b04d7507a82416248ad82148c7490c9c02bbbfa4440afcd5916105f1 WHIRLPOOL 28112183f86f47029765758fdf61187c73e3282470f0b51c4f22d4c2b4f24fbdfed47fb0777c68e79ba311407f6e8f3eec85339d5fd0da590ffc09ba13286c29
+MISC metadata.xml 455 SHA256 3752be463cc35dcb6d06fad3dd5a4387a42d8c63959eec026acc78542eb896cf SHA512 2c3718417db689cc74201c24c326a1967a6e551cfa2310b5816b40d1df8de5ec92ef31b62542fbb46665d67c9036ee77bba136124f291354df5b22125922a703 WHIRLPOOL bb1d6a6769fde54baba077023f17af5da4641d53c4cbbef839a4269c4303887d3c447c7ac71b4d6dcb74e63ba213cb675a897e67e8d32193c89e987b71e4c89b
diff --git a/dev-go/siphash/metadata.xml b/dev-go/siphash/metadata.xml
new file mode 100644
index 000000000000..969bb1d92543
--- /dev/null
+++ b/dev-go/siphash/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Gentoo Proxy Maintainers Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>Marek.Szuba@cern.ch</email>
+ <name>Marek Szuba</name>
+ <description>Proxied maintainer; set to assignee in all bugs</description>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-go/siphash/siphash-1.0.0.ebuild b/dev-go/siphash/siphash-1.0.0.ebuild
new file mode 100644
index 000000000000..4a59f0445306
--- /dev/null
+++ b/dev-go/siphash/siphash-1.0.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit golang-build golang-vcs-snapshot
+
+EGO_SRC=github.com/dchest/siphash
+EGO_PN=${EGO_SRC}/...
+EGIT_COMMIT="v${PV}"
+SRC_URI="https://github.com/dchest/siphash/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+DESCRIPTION="Go implementation of SipHash-2.4"
+HOMEPAGE="https://github.com/dchest/siphash"
+
+KEYWORDS="~amd64"
+
+LICENSE="CC0-1.0"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""