summaryrefslogtreecommitdiff
path: root/dev-go
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2024-05-01 21:11:02 -0700
committerZac Medico <zmedico@gentoo.org>2024-05-01 21:19:55 -0700
commit334b68c9fbed092c3622e4d65a8ff2526ec5d3a4 (patch)
treea7092622e48199c963156c943a3c775369ae7c19 /dev-go
parentx11-wm/notion: drop merged patch from 9999 (diff)
downloadgentoo-334b68c9fbed092c3622e4d65a8ff2526ec5d3a4.tar.gz
gentoo-334b68c9fbed092c3622e4d65a8ff2526ec5d3a4.tar.bz2
gentoo-334b68c9fbed092c3622e4d65a8ff2526ec5d3a4.zip
dev-go/go-tools: add 0.20.0
Also set RESTRICT="test" because there are many failures. Bug: https://bugs.gentoo.org/904314 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-go')
-rw-r--r--dev-go/go-tools/Manifest2
-rw-r--r--dev-go/go-tools/go-tools-0.20.0.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-go/go-tools/Manifest b/dev-go/go-tools/Manifest
index af0b9654c8c0..69c562a90597 100644
--- a/dev-go/go-tools/Manifest
+++ b/dev-go/go-tools/Manifest
@@ -1,2 +1,4 @@
DIST go-tools-0.1.10-deps.tar.xz 16247548 BLAKE2B 7dc27e377eec3c7fa49d37614d2b7b826735228ae3b22b9481bcba4e344afd51145e98a885c33b5b732d9e6382a5f50a94efcd6f3a820088dd528e561bd5fae0 SHA512 a7bcb32b0393640dd603e07958dc70abba750d219b46f2de649d7e3644432364798c5227df5d764ab6e62d01b60f10d74668914ea09f469ce19134bc934d17ba
DIST go-tools-0.1.10.tar.gz 3014465 BLAKE2B f3b6129ad00385539eab3426bc542a120bd41d3984174d5d8b91bee6435d7a179c0058f2a50de3235a07e5b67f6d9657288bd578591d61187447441bb6408e76 SHA512 9c817c98739a1788b7fb459728528b5c647226e64df495661c1b3027bfa571e884d6c28d8796558b65e2ba54774976897bddcd052568f33d4e30ce8ee5d883e1
+DIST go-tools-0.20.0-deps.tar.xz 383336 BLAKE2B 0bddd81087bae28c2d874a2ea647a5293b32895fded73351813c1542066d7ee1a0d3d8a0aaa5c13cea3e117c692b46690282f992293d83c8fbd2901adc71911f SHA512 eeaa8a85ec81eed757156f99d6bc99f69c89debf52eb862e870c7effb7a0b800736e04f507efa19be122a5246aed2519d4c33bd850bc790947f065ab8a87a323
+DIST go-tools-0.20.0.tar.gz 3779878 BLAKE2B 42175d921dfb5acb25c9eee224138675619860aefaca09db8e354481c146faa52b2fcc64d99953d8508a79ce8375ebcc42a1e7d20f4721e55b8c843989565fbc SHA512 c67706593d0a48f941955e40cadc1e39961b07ba51c9342b302ba99f93a1e55b9feec21d6171ee370f96293253be27b480274d48a16eff1055373f81b73f2dd9
diff --git a/dev-go/go-tools/go-tools-0.20.0.ebuild b/dev-go/go-tools/go-tools-0.20.0.ebuild
new file mode 100644
index 000000000000..fe369f14fa0a
--- /dev/null
+++ b/dev-go/go-tools/go-tools-0.20.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="Tools that support the Go programming language (godoc, etc.)"
+HOMEPAGE="https://godoc.org/golang.org/x/tools"
+SRC_URI="https://github.com/golang/tools/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~zmedico/dist/${P}-deps.tar.xz"
+S=${WORKDIR}/${P#go-}
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+# Many test failures.
+RESTRICT="test"
+
+GO_TOOLS_BINS=(
+ authtest benchcmp bisect bundle callgraph compilebench cookieauth deadcode
+ defers digraph eg fieldalignment file2fuzz findcall fiximports fuzz-driver
+ fuzz-runner gitauth go-contrib-init godex godoc goimports gomvpkg gonew
+ gopackages gorename gostacks gotype goyacc html2article httpmux ifaceassert
+ lostcancel netrcauth nilness nodecount play present present2md shadow
+ splitdwarf ssadump stress stringer stringintconv toolstash unmarshal
+ unusedresult
+)
+
+src_compile() {
+ local bin packages
+ readarray -t packages < <(ego list ./...)
+ GOBIN="${S}/bin" nonfatal ego install -work "${packages[@]}" || true
+ for bin in "${GO_TOOLS_BINS[@]}"; do
+ [[ -x ${S}/bin/${bin} ]] || \
+ die "File not found, check build log: ${S}/bin/${bin}"
+ done
+}
+
+src_test() {
+ ego test -work ./...
+}
+
+src_install() {
+ # bug 558818: install binaries in $GOROOT/bin to avoid file collisions
+ local goroot=$(go env GOROOT)
+ goroot=${goroot#${EPREFIX}}
+ exeinto "${goroot}/bin"
+ doexe bin/*
+ dodir /usr/bin
+ ln "${ED}/${goroot}/bin/godoc" "${ED}/usr/bin/godoc" || die
+}