summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:07:10 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:09:30 +0100
commit0c437d788418f14c6c9d53fdb95ff8ecbb93a0d3 (patch)
treeba376e182f28189fb5ce49eb803d4ae0159c7a1e /dev-haskell/email-validate/email-validate-2.3.2.19.ebuild
parentdev-haskell/ed25519: Hackage revision bump (diff)
downloadgentoo-0c437d788418f14c6c9d53fdb95ff8ecbb93a0d3.tar.gz
gentoo-0c437d788418f14c6c9d53fdb95ff8ecbb93a0d3.tar.bz2
gentoo-0c437d788418f14c6c9d53fdb95ff8ecbb93a0d3.zip
dev-haskell/email-validate: add 2.3.2.19
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/email-validate/email-validate-2.3.2.19.ebuild')
-rw-r--r--dev-haskell/email-validate/email-validate-2.3.2.19.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-haskell/email-validate/email-validate-2.3.2.19.ebuild b/dev-haskell/email-validate/email-validate-2.3.2.19.ebuild
new file mode 100644
index 000000000000..32b9164dfe5a
--- /dev/null
+++ b/dev-haskell/email-validate/email-validate-2.3.2.19.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Email address validation"
+HOMEPAGE="https://github.com/Porges/email-validate-hs"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-haskell/attoparsec-0.10.0:=[profile?] <dev-haskell/attoparsec-0.15:=[profile?]
+ >=dev-lang/ghc-8.10.6:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.1.0
+ test? (
+ >=dev-haskell/hspec-2.2.3 <dev-haskell/hspec-2.12
+ >=dev-haskell/quickcheck-2.4 <dev-haskell/quickcheck-2.15
+ )
+"