summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-12-14 23:06:19 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2019-12-14 23:47:21 +0000
commit9d48bfe76b896e8352664d88c601ec6cc9e2d020 (patch)
treec07b0333c1bb294121e99167a83aacd56dc203de /dev-haskell/encoding/encoding-0.8.2.ebuild
parentdev-haskell/executable-path: bump up to 0.0.3.1 (diff)
downloadgentoo-9d48bfe76b896e8352664d88c601ec6cc9e2d020.tar.gz
gentoo-9d48bfe76b896e8352664d88c601ec6cc9e2d020.tar.bz2
gentoo-9d48bfe76b896e8352664d88c601ec6cc9e2d020.zip
dev-haskell/encoding: bump up to 0.8.2
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/encoding/encoding-0.8.2.ebuild')
-rw-r--r--dev-haskell/encoding/encoding-0.8.2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-haskell/encoding/encoding-0.8.2.ebuild b/dev-haskell/encoding/encoding-0.8.2.ebuild
new file mode 100644
index 000000000000..695bd93c4395
--- /dev/null
+++ b/dev-haskell/encoding/encoding-0.8.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A library for various character encodings"
+HOMEPAGE="http://code.haskell.org/encoding/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+systemencoding"
+
+RDEPEND=">=dev-haskell/extensible-exceptions-0.1:=[profile?] <dev-haskell/extensible-exceptions-0.2:=[profile?]
+ >=dev-haskell/mtl-2.0:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/regex-compat-0.71:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.24
+ >=dev-haskell/haxml-1.22 <dev-haskell/haxml-1.26
+ test? ( dev-haskell/hunit
+ dev-haskell/quickcheck )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-cabal22.patch
+)
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'regex-compat >=0.71 && <0.95' 'regex-compat >=0.71' \
+ 'containers >=0.4 && <0.6' 'containers >=0.4 && <0.7'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag systemencoding systemencoding)
+}