summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormatoro <matoro@users.noreply.github.com>2022-07-12 11:52:28 -0400
committerSam James <sam@gentoo.org>2022-07-22 22:15:22 +0000
commitbfd114e1e0d3a145a85de6aad10450fb4112427c (patch)
tree0aaccdbb0add2da3a736eeef17b12927ff7a0321 /dev-haskell/invariant/invariant-0.5.5.ebuild
parentdev-haskell/integer-logarithms: revbump 1.0.3.1-r1 (diff)
downloadgentoo-bfd114e1e0d3a145a85de6aad10450fb4112427c.tar.gz
gentoo-bfd114e1e0d3a145a85de6aad10450fb4112427c.tar.bz2
gentoo-bfd114e1e0d3a145a85de6aad10450fb4112427c.zip
dev-haskell/invariant: add 0.5.5
Signed-off-by: matoro <matoro@users.noreply.github.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/invariant/invariant-0.5.5.ebuild')
-rw-r--r--dev-haskell/invariant/invariant-0.5.5.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-haskell/invariant/invariant-0.5.5.ebuild b/dev-haskell/invariant/invariant-0.5.5.ebuild
new file mode 100644
index 000000000000..8bcc5e3f34ad
--- /dev/null
+++ b/dev-haskell/invariant/invariant-0.5.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Haskell98 invariant functors"
+HOMEPAGE="https://github.com/nfrisby/invariant-functors"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND=">=dev-haskell/bifunctors-5.2:=[profile?] <dev-haskell/bifunctors-6:=[profile?]
+ >=dev-haskell/comonad-5:=[profile?] <dev-haskell/comonad-6:=[profile?]
+ >=dev-haskell/contravariant-0.5:=[profile?] <dev-haskell/contravariant-2:=[profile?]
+ >=dev-haskell/profunctors-5.2.1:=[profile?] <dev-haskell/profunctors-6:=[profile?]
+ >=dev-haskell/statevar-1.1:=[profile?] <dev-haskell/statevar-2:=[profile?]
+ >=dev-haskell/stm-2.2:=[profile?] <dev-haskell/stm-3:=[profile?]
+ >=dev-haskell/tagged-0.7.3:=[profile?] <dev-haskell/tagged-1:=[profile?]
+ >=dev-haskell/th-abstraction-0.4:=[profile?] <dev-haskell/th-abstraction-0.5:=[profile?]
+ >=dev-haskell/transformers-compat-0.3:=[profile?] <dev-haskell/transformers-compat-1:=[profile?]
+ >=dev-haskell/unordered-containers-0.2.4:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( >=dev-haskell/hspec-1.8
+ >=dev-haskell/quickcheck-2.11 <dev-haskell/quickcheck-3 )
+"