summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-08-03 08:46:31 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-03 08:46:31 +0100
commit935e4e45af49d0e9925fe6d1bddff318c8156c0a (patch)
treeb1c9b1b051d629819113a3b037eb1d2d45cc6607 /dev-haskell/language-bash/language-bash-0.9.0.ebuild
parentdev-util/bnfc: bump up to 2.8.3 (diff)
downloadgentoo-935e4e45af49d0e9925fe6d1bddff318c8156c0a.tar.gz
gentoo-935e4e45af49d0e9925fe6d1bddff318c8156c0a.tar.bz2
gentoo-935e4e45af49d0e9925fe6d1bddff318c8156c0a.zip
dev-haskell/language-bash: bump up to 0.9.0
Reported-by: Toralf Förster Closes: https://bugs.gentoo.org/735646 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/language-bash/language-bash-0.9.0.ebuild')
-rw-r--r--dev-haskell/language-bash/language-bash-0.9.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-haskell/language-bash/language-bash-0.9.0.ebuild b/dev-haskell/language-bash/language-bash-0.9.0.ebuild
new file mode 100644
index 000000000000..442f6094633e
--- /dev/null
+++ b/dev-haskell/language-bash/language-bash-0.9.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.2
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Parsing and pretty-printing Bash shell scripts"
+HOMEPAGE="https://github.com/knrafto/language-bash/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # fails, "getDirectoryContents:openDirStream: does not exist"
+
+RDEPEND=">=dev-haskell/parsec-3.0:=[profile?] <dev-haskell/parsec-4.0:=[profile?]
+ >=dev-haskell/prettyprinter-1.2:=[profile?] <dev-haskell/prettyprinter-2.0:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( dev-haskell/quickcheck
+ dev-haskell/tasty
+ dev-haskell/tasty-expected-failure
+ dev-haskell/tasty-golden
+ dev-haskell/tasty-hunit
+ dev-haskell/tasty-quickcheck )
+"