summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:09:12 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:09:58 +0100
commit938bd0aa8b5ce710735f51956951f2ab7ad2c252 (patch)
treec75e7b3a64b40f392635379dcbcef5a663566b14 /dev-haskell/primitive/primitive-0.7.4.0.ebuild
parentdev-haskell/prettyprinter: add 1.7.1 (diff)
downloadgentoo-938bd0aa8b5ce710735f51956951f2ab7ad2c252.tar.gz
gentoo-938bd0aa8b5ce710735f51956951f2ab7ad2c252.tar.bz2
gentoo-938bd0aa8b5ce710735f51956951f2ab7ad2c252.zip
dev-haskell/primitive: add 0.7.4.0
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/primitive/primitive-0.7.4.0.ebuild')
-rw-r--r--dev-haskell/primitive/primitive-0.7.4.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-haskell/primitive/primitive-0.7.4.0.ebuild b/dev-haskell/primitive/primitive-0.7.4.0.ebuild
new file mode 100644
index 000000000000..1a4f19a9b655
--- /dev/null
+++ b/dev-haskell/primitive/primitive-0.7.4.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.3.0
+
+CABAL_HACKAGE_REVISION=1
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Primitive memory-related operations"
+HOMEPAGE="https://github.com/haskell/primitive"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux"
+
+CABAL_CHDEPS=(
+ 'tasty ^>= 1.2 || ^>= 1.3 || ^>= 1.4' 'tasty >= 1.2'
+)
+
+RDEPEND="
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? (
+ dev-haskell/base-orphans
+ >=dev-haskell/quickcheck-2.13 <dev-haskell/quickcheck-2.15
+ >=dev-haskell/quickcheck-classes-base-0.6 <dev-haskell/quickcheck-classes-base-0.7
+ dev-haskell/tagged
+ >=dev-haskell/tasty-1.2
+ dev-haskell/tasty-quickcheck
+ dev-haskell/transformers-compat
+ )
+"
+
+pkg_pretend() {
+ if use test; then
+ ewarn "The \"test\" USE flag for this package creates cycles within the"
+ ewarn "dependency graph. This may give you problems during 'haskell-updater' runs."
+ ewarn "It is recommended to leave it disabled unless explicitly testing the package."
+ fi
+}