summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormatoro <matoro@users.noreply.github.com>2022-07-11 23:44:56 -0400
committerSam James <sam@gentoo.org>2022-07-22 22:16:00 +0000
commit3cc441e8607f2e1cc4361f3c4af42a86f3e0a1c3 (patch)
treeeac6f2f62834b94b6d40c06a3f89d0b75e98a7c5 /dev-haskell/vector-algorithms/vector-algorithms-0.8.0.4.ebuild
parentdev-haskell/vector: add 0.12.3.1 (diff)
downloadgentoo-3cc441e8607f2e1cc4361f3c4af42a86f3e0a1c3.tar.gz
gentoo-3cc441e8607f2e1cc4361f3c4af42a86f3e0a1c3.tar.bz2
gentoo-3cc441e8607f2e1cc4361f3c4af42a86f3e0a1c3.zip
dev-haskell/vector-algorithms: add 0.8.0.4
Signed-off-by: matoro <matoro@users.noreply.github.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/vector-algorithms/vector-algorithms-0.8.0.4.ebuild')
-rw-r--r--dev-haskell/vector-algorithms/vector-algorithms-0.8.0.4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-haskell/vector-algorithms/vector-algorithms-0.8.0.4.ebuild b/dev-haskell/vector-algorithms/vector-algorithms-0.8.0.4.ebuild
new file mode 100644
index 000000000000..fc5b50747cec
--- /dev/null
+++ b/dev-haskell/vector-algorithms/vector-algorithms-0.8.0.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.7.9999
+#hackport: flags: -llvm
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Efficient algorithms for vector arrays"
+HOMEPAGE="https://github.com/erikd/vector-algorithms/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="+bench +boundschecks internalchecks +properties unsafechecks"
+
+RDEPEND=">=dev-haskell/primitive-0.3:=[profile?] <dev-haskell/primitive-0.8:=[profile?]
+ >=dev-haskell/tagged-0.4:=[profile?] <dev-haskell/tagged-0.9:=[profile?]
+ >=dev-haskell/vector-0.6:=[profile?] <dev-haskell/vector-0.13:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( properties? ( >dev-haskell/quickcheck-2.9 <dev-haskell/quickcheck-2.15 ) )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag bench bench) \
+ $(cabal_flag boundschecks boundschecks) \
+ $(cabal_flag internalchecks internalchecks) \
+ --flag=-llvm \
+ $(cabal_flag properties properties) \
+ $(cabal_flag unsafechecks unsafechecks)
+}