summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:11:11 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:10:29 +0100
commit132cbc05055552cb9e59c5d77e1f49d2991c5c95 (patch)
treebc740e20187e9f0529094a342a334eee1b84c363 /dev-haskell/yaml
parentdev-haskell/xss-sanitize: add 0.3.7.2 (diff)
downloadgentoo-132cbc05055552cb9e59c5d77e1f49d2991c5c95.tar.gz
gentoo-132cbc05055552cb9e59c5d77e1f49d2991c5c95.tar.bz2
gentoo-132cbc05055552cb9e59c5d77e1f49d2991c5c95.zip
dev-haskell/yaml: add 0.11.11.2
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/yaml')
-rw-r--r--dev-haskell/yaml/Manifest1
-rw-r--r--dev-haskell/yaml/metadata.xml9
-rw-r--r--dev-haskell/yaml/yaml-0.11.11.2.ebuild65
3 files changed, 67 insertions, 8 deletions
diff --git a/dev-haskell/yaml/Manifest b/dev-haskell/yaml/Manifest
index b578e00692e0..ab07d5605989 100644
--- a/dev-haskell/yaml/Manifest
+++ b/dev-haskell/yaml/Manifest
@@ -1 +1,2 @@
+DIST yaml-0.11.11.2.tar.gz 31926 BLAKE2B 3c8fb1973a8d8e03fa626122862c124fd6cf8b0f5ffbcc2c6d9566fcca84fb1428857c916b5f072de13dc9198fbfec8bf2c8b3b69836eb351c24fe42cb496420 SHA512 419b5fb86d96d2e7adda5b0091d9d32eb2a5c964d32ca9d72e83feb14aef738e5029f43d1760a91ae83c47aebd8d2211e255dfdf28e95c64be3fbb2380cfaf60
DIST yaml-0.11.8.0.tar.gz 31674 BLAKE2B a4c508eecb4e5b931e6832ceee0bd694fc6879cc6c3482a48e44c1b865207e3525c52cd51a9e2ec74a9ef98e1537f8d559151da80c0ef07351ace1665e5b5f09 SHA512 f47ae0a158bfd323e06ff31db348f916077882f4198b160c7f3f88e89ae0e62a9f17ff5ba29c15a1d74a52d040245613eced5267c38f9658d0a19007efb402f7
diff --git a/dev-haskell/yaml/metadata.xml b/dev-haskell/yaml/metadata.xml
index 3d126b223c2e..71b8b45b1435 100644
--- a/dev-haskell/yaml/metadata.xml
+++ b/dev-haskell/yaml/metadata.xml
@@ -5,18 +5,11 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- Provides support for parsing and emitting Yaml documents.
-
- This package includes the full libyaml C library version 0.1.12 by Kirill
- Simonov (&lt;http://pyyaml.org/wiki/LibYAML&gt;) in the package so you
- don't need to worry about any non-Haskell dependencies.
- </longdescription>
<use>
- <flag name="examples">Install the haskell-yaml-examples executable</flag>
<flag name="executable">Install the yaml2json and json2yaml executables</flag>
</use>
<upstream>
+ <remote-id type="hackage">yaml</remote-id>
<remote-id type="github">snoyberg/yaml</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-haskell/yaml/yaml-0.11.11.2.ebuild b/dev-haskell/yaml/yaml-0.11.11.2.ebuild
new file mode 100644
index 000000000000..9eb42d269c67
--- /dev/null
+++ b/dev-haskell/yaml/yaml-0.11.11.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Support for parsing and rendering YAML documents"
+HOMEPAGE="https://github.com/snoyberg/yaml#readme"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="examples executable"
+
+CABAL_CHDEPS=(
+ 'executable examples' 'executable haskell-yaml-examples'
+)
+
+RDEPEND=">=dev-haskell/aeson-0.11:=[profile?]
+ >=dev-haskell/attoparsec-0.11.3.0:=[profile?]
+ >=dev-haskell/conduit-1.2.8:=[profile?] <dev-haskell/conduit-1.4:=[profile?]
+ >=dev-haskell/libyaml-0.1:=[profile?] <dev-haskell/libyaml-0.2:=[profile?]
+ >=dev-haskell/resourcet-0.3:=[profile?] <dev-haskell/resourcet-1.4:=[profile?]
+ >=dev-haskell/scientific-0.3:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+ examples? ( dev-haskell/raw-strings-qq:=[profile?] )
+ executable? ( dev-haskell/optparse-applicative:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+ test? ( dev-haskell/base-compat
+ >=dev-haskell/hspec-1.3
+ dev-haskell/hunit
+ dev-haskell/mockery
+ dev-haskell/temporary
+ !examples? ( dev-haskell/raw-strings-qq ) )
+"
+
+src_configure() {
+ local examples_flag="no-examples"
+ use examples && examples_flag="-no-examples"
+
+ local exe_flag="no-exe"
+ use executable && exe_flag="-no-exe"
+
+ haskell-cabal_src_configure \
+ --flag="${examples_flag}" \
+ --flag="${exe_flag}"
+}
+
+pkg_postinst() {
+ if use examples; then
+ elog "The executable installed with this package (normally named 'examples')"
+ elog "has been renamed to 'haskell-yaml-examples' to help prevent name collisions."
+ fi
+
+ haskell-cabal_pkg_postinst
+}