summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-08-07 22:17:20 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-07 22:17:32 +0100
commita61cae65f4cf0813e3efa7eb9ac53b054856e100 (patch)
tree214d569e8fd833f2f922240e118e06aa6d2f1b91 /dev-haskell
parentdev-lang/perl: 5.30.3-r2 rework patching bundle logic (diff)
downloadgentoo-a61cae65f4cf0813e3efa7eb9ac53b054856e100.tar.gz
gentoo-a61cae65f4cf0813e3efa7eb9ac53b054856e100.tar.bz2
gentoo-a61cae65f4cf0813e3efa7eb9ac53b054856e100.zip
dev-haskell/idiii: tweak for ghc-8.8
Reported-by: Toralf Förster Closes: https://bugs.gentoo.org/736280 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/idiii/files/idiii-0.1.3.3-fold.patch7
-rw-r--r--dev-haskell/idiii/idiii-0.1.3.3.ebuild7
2 files changed, 11 insertions, 3 deletions
diff --git a/dev-haskell/idiii/files/idiii-0.1.3.3-fold.patch b/dev-haskell/idiii/files/idiii-0.1.3.3-fold.patch
new file mode 100644
index 000000000000..0bd0469e53af
--- /dev/null
+++ b/dev-haskell/idiii/files/idiii-0.1.3.3-fold.patch
@@ -0,0 +1,7 @@
+--- a/src/ID3/Type/Tag.hs
++++ b/src/ID3/Type/Tag.hs
+@@ -89,3 +89,3 @@ getActualSize t = (footerSize t) + (framesSize (t^.frames)) + (extHSize t)
+ framesSize :: Map FrameID ID3Frame -> FrameSize
+-framesSize fs = Map.fold (\fr x -> fr^.frHeader^.frSize + 10 + x) 0 fs
++framesSize fs = Map.foldr (\fr x -> fr^.frHeader^.frSize + 10 + x) 0 fs
+ footerSize :: ID3Tag -> Integer
diff --git a/dev-haskell/idiii/idiii-0.1.3.3.ebuild b/dev-haskell/idiii/idiii-0.1.3.3.ebuild
index 92147c2965b5..874e97f42508 100644
--- a/dev-haskell/idiii/idiii-0.1.3.3.ebuild
+++ b/dev-haskell/idiii/idiii-0.1.3.3.ebuild
@@ -5,11 +5,11 @@ EAPI=6
# ebuild generated by hackport 0.5.9999
-CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour" # Broken test-suite: missing files
inherit haskell-cabal
DESCRIPTION="ID3v2 (tagging standard for MP3 files) library"
-HOMEPAGE="https://hackage.haskell.org/package/idiii"
+HOMEPAGE="http://hackage.haskell.org/package/idiii"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
@@ -28,5 +28,6 @@ RDEPEND="dev-haskell/data-accessor:=[profile?]
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.8
- test? ( dev-haskell/hunit )
"
+
+PATCHES=("${FILESDIR}"/${P}-fold.patch)