summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2016-02-18 22:07:50 +0000
committerJames Le Cuirot <chewi@gentoo.org>2016-02-18 22:08:52 +0000
commit913abde5997fd06e4f6666770624c3bb09f9b3c5 (patch)
tree9279379ae6e9d5e561344e7fa2014fc3a71ef64b /dev-java/annogen/annogen-0.1.0-r3.ebuild
parentmedia-libs/babl: Version bump (diff)
downloadgentoo-913abde5997fd06e4f6666770624c3bb09f9b3c5.tar.gz
gentoo-913abde5997fd06e4f6666770624c3bb09f9b3c5.tar.bz2
gentoo-913abde5997fd06e4f6666770624c3bb09f9b3c5.zip
dev-java/annogen: Drop jdk-with-com-sun dep, fix jdk/jre reversal
Straight to stable as it shouldn't affect the build and jdk-with-com-sun really needs to go. It still can't just yet but at least ppc64 is clear now. Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-java/annogen/annogen-0.1.0-r3.ebuild')
-rw-r--r--dev-java/annogen/annogen-0.1.0-r3.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-java/annogen/annogen-0.1.0-r3.ebuild b/dev-java/annogen/annogen-0.1.0-r3.ebuild
new file mode 100644
index 000000000000..96d70fd8e2e3
--- /dev/null
+++ b/dev-java/annogen/annogen-0.1.0-r3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="A tool which helps you work with JSR175 annotations"
+HOMEPAGE="https://github.com/codehaus/annogen"
+SRC_URI="http://dist.codehaus.org/${PN}/distributions/${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~ppc64 ~x86"
+
+CDEPEND="
+ dev-java/qdox:1.6
+ dev-java/ant-core:0"
+
+RDEPEND="
+ ${CDEPEND}
+ >=virtual/jre-1.6"
+
+DEPEND="
+ ${CDEPEND}
+ app-arch/unzip
+ >=virtual/jdk-1.6"
+
+# com.sun.mirror.declaration was removed from JDK 7 onwards.
+# These two files are just interfaces anyway.
+JAVA_RM_FILES=(
+ org/codehaus/annogen/view/MirrorAnnoViewer.java
+ org/codehaus/annogen/override/MirrorElementIdPool.java
+)
+
+JAVA_GENTOO_CLASSPATH="
+ ant-core
+ qdox-1.6
+"
+
+src_unpack() {
+ default
+ unzip -o -q "${S}/${PN}-src-${PV}.zip" || die
+}
+
+java_prepare() {
+ java-pkg_clean
+ rm -rf examples || die
+}
+
+src_compile() {
+ # Needed for com.sun.* imports
+ JAVA_GENTOO_CLASSPATH_EXTRA="$(java-config -t)" \
+ java-pkg-simple_src_compile
+}