summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2020-10-01 20:00:45 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2020-10-01 20:15:50 +0200
commit9fda3f7ddbde84a4a7a56df8b79245d9a34efb6c (patch)
tree1d01baf3aaed0a7a115b0afe3613b2aec95fca32 /dev-java/ant-apache-bsf/ant-apache-bsf-1.10.9.ebuild
parentdev-java/ant-apache-bcel: bump to 1.10.9 (diff)
downloadgentoo-9fda3f7ddbde84a4a7a56df8b79245d9a34efb6c.tar.gz
gentoo-9fda3f7ddbde84a4a7a56df8b79245d9a34efb6c.tar.bz2
gentoo-9fda3f7ddbde84a4a7a56df8b79245d9a34efb6c.zip
dev-java/ant-apache-bsf: bump to 1.10.9
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java/ant-apache-bsf/ant-apache-bsf-1.10.9.ebuild')
-rw-r--r--dev-java/ant-apache-bsf/ant-apache-bsf-1.10.9.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-java/ant-apache-bsf/ant-apache-bsf-1.10.9.ebuild b/dev-java/ant-apache-bsf/ant-apache-bsf-1.10.9.ebuild
new file mode 100644
index 000000000000..4fd4bd7de77a
--- /dev/null
+++ b/dev-java/ant-apache-bsf/ant-apache-bsf-1.10.9.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ANT_TASK_JDKVER=1.8
+ANT_TASK_JREVER=1.8
+ANT_TASK_DEPNAME="bsf-2.3"
+
+inherit ant-tasks
+
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="python javascript tcl"
+
+DEPEND=">=dev-java/bsf-2.4.0-r1:2.3[python?,javascript?,tcl?]"
+RDEPEND="${DEPEND}"
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "Also, >=dev-java/bsf-2.4.0-r1 adds optional support for groovy,"
+ elog "ruby and beanshell. See its postinst elog messages for instructions."
+ fi
+}