summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-04-27 20:18:37 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-04-27 20:18:37 +0200
commitc2aaac17e1fb49fe8bce439d36b751f5c8dcc6f5 (patch)
treec970ce19bf5c770c069943230cb41412f43d48f3 /dev-java/commons-io
parentdev-java/slf4j-simple: removed obsolete 1.7.7 (diff)
downloadgentoo-c2aaac17e1fb49fe8bce439d36b751f5c8dcc6f5.tar.gz
gentoo-c2aaac17e1fb49fe8bce439d36b751f5c8dcc6f5.tar.bz2
gentoo-c2aaac17e1fb49fe8bce439d36b751f5c8dcc6f5.zip
dev-java/commons-io: removed obsolete and vulnerable 2.4
Bug: https://bugs.gentoo.org/782568 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java/commons-io')
-rw-r--r--dev-java/commons-io/Manifest1
-rw-r--r--dev-java/commons-io/commons-io-2.4.ebuild58
2 files changed, 0 insertions, 59 deletions
diff --git a/dev-java/commons-io/Manifest b/dev-java/commons-io/Manifest
index 564428f27215..e3fecd8f067d 100644
--- a/dev-java/commons-io/Manifest
+++ b/dev-java/commons-io/Manifest
@@ -1,2 +1 @@
-DIST commons-io-2.4-src.tar.gz 330961 BLAKE2B 1a1ae7c968bfc38b4a4f3c4c131de088c4efdd8fff0858e7493e057909076c74d4b0ebee1999ef01af9636d88600ecca71bb0808686a6f9c1a20f4d7a5cbe6e6 SHA512 69ac5f7b8de952d8b519ad89d4e9a33a9d269af0e68b735c0180ee8853a30e2a09147ceac362626a2fb3a041bd46eca094be2661ff280c1bab54a0548cae0aee
DIST commons-io-2.8.0-sources.tar.gz 445833 BLAKE2B 4fc6f9b66fa88adfc110742bd3eab55cbe165552f71d665f70fd54d4b0b79c4e76b45fccdb78c6ef64e476f54efc8b51adc9b2d7e880c71dbdb6bc5883d2fe55 SHA512 6189c72eff8661bfb8cfed95dd7ee32578b24b50f6586d4628a4dbfd3618853a72eb73da311729e55742ace47b2d38d3ce130ab87b684494d8ce33d1ccf14a2d
diff --git a/dev-java/commons-io/commons-io-2.4.ebuild b/dev-java/commons-io/commons-io-2.4.ebuild
deleted file mode 100644
index 6b4ce6ef64d4..000000000000
--- a/dev-java/commons-io/commons-io-2.4.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-JAVA_PKG_IUSE="doc source"
-
-inherit java-pkg-2 java-ant-2 eutils
-
-MY_P=${P}-src
-DESCRIPTION="Utility classes, stream implementations, file filters, and endian classes"
-HOMEPAGE="http://commons.apache.org/io/"
-SRC_URI="mirror://apache/commons/io/source/${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="1"
-KEYWORDS="amd64 ~arm64 ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=virtual/jre-1.6"
-DEPEND=">=virtual/jdk-1.6
- test? (
- dev-java/ant-junit:0
- dev-java/junit:4
- )"
-
-S=${WORKDIR}/${MY_P}
-
-EANT_EXTRA_ARGS="-Dcomponent.version=${PV}"
-JAVA_ANT_REWRITE_CLASSPATH="yes"
-JAVA_ANT_ENCODING="ISO-8859-1"
-
-java_prepare() {
- # Setting java.io.tmpdir doesn't have effect unless we do this because the vm is forked
- java-ant_xml-rewrite -f build.xml --change -e junit -a clonevm -v "true"
-}
-
-src_test() {
- if [[ ${EUID} -ne 0 ]] ; then
- ANT_OPTS="-Dskip.download=1 -Djava.io.tmpdir=${T} -Duser.home=${T}" \
- ANT_TASKS="ant-junit" \
- eant test \
- -Dgentoo.classpath="$(java-pkg_getjars junit-4):${S}/src/test/resources" \
- -Dlibdir="libdir" \
- -Djava.io.tmpdir="${T}"
- else
- elog "Tests fail unless userpriv is enabled because they test for"
- elog "file permissions which doesn't work when run as root."
- fi
-}
-
-src_install() {
- java-pkg_newjar target/${P}.jar
-
- dodoc RELEASE-NOTES.txt
- use doc && java-pkg_dojavadoc target/apidocs
- use source && java-pkg_dosrc src/main/java/*
-}