summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/cpptasks
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/cpptasks')
-rw-r--r--dev-java/cpptasks/Manifest2
-rw-r--r--dev-java/cpptasks/cpptasks-1.0_beta4-r2.ebuild57
-rw-r--r--dev-java/cpptasks/cpptasks-1.0_beta5.ebuild59
-rw-r--r--dev-java/cpptasks/files/1.0b4-profiling.patch27
-rw-r--r--dev-java/cpptasks/files/antlib.xml22
-rw-r--r--dev-java/cpptasks/metadata.xml8
6 files changed, 175 insertions, 0 deletions
diff --git a/dev-java/cpptasks/Manifest b/dev-java/cpptasks/Manifest
new file mode 100644
index 000000000000..578f75c8e641
--- /dev/null
+++ b/dev-java/cpptasks/Manifest
@@ -0,0 +1,2 @@
+DIST cpptasks-1.0b4.tar.gz 879715 SHA256 3472af7389c5a7daaff48a054c2b9f10994b55352025b8a2249a7dfcebca14c8 SHA512 6e12ac6f4a96d36b50e3f0d105038feef16e70f0980959671245bc88dbd170a9dd42b39b884a0b2f6e7d055b9588462d0a290587919605e8503979cc575aede5 WHIRLPOOL c4f264e275201aacf732a73fb52f2aad02b26581ca4572d30ab4ab768ff29a66f5c01f617efa38a49ac93b779d63711aa479e2143c6b01b443c4fe1c973fd3bd
+DIST cpptasks-1.0b5.tar.gz 902930 SHA256 d181cee0c4e28bed202f8bf582dc42bbc824c7712ea29c7b17f036fc7cdfc209 SHA512 620d16e60cdd4d8a09efe6c5889ec1beb20d38df3a7ebf337de546cd60881b4c22a08f24374e7dac02dbbb3b23defbb740a70f1d0ff59212496e631251f0e32c WHIRLPOOL 1eb3a0726d43a40453a7a70c89b2fdf8880979a52f8dac6cab9a01800184c72d084d603a647804dd6a55a162a20fd2102818fb415336e21beeb010bd3b7eb196
diff --git a/dev-java/cpptasks/cpptasks-1.0_beta4-r2.ebuild b/dev-java/cpptasks/cpptasks-1.0_beta4-r2.ebuild
new file mode 100644
index 000000000000..ee4d19e8cba1
--- /dev/null
+++ b/dev-java/cpptasks/cpptasks-1.0_beta4-r2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit java-pkg-2 java-ant-2
+
+MY_P="${PN}-${PV/_beta/b}"
+DESCRIPTION="Ant tasks to compile various source languages and produce executables, shared and static libraries"
+HOMEPAGE="http://ant-contrib.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ant-contrib/${MY_P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="doc source examples"
+
+RDEPEND=">=virtual/jre-1.4
+ >=dev-java/ant-core-1.7
+ >=dev-java/xerces-2.7"
+DEPEND=">=virtual/jdk-1.4
+ ${RDEPEND}
+ source? ( app-arch/zip )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ # https://sourceforge.net/tracker/index.php?func=detail&aid=829906&group_id=36177&atid=416920
+ # https://bugs.gentoo.org/show_bug.cgi?id=156596
+ epatch "${FILESDIR}/1.0b4-profiling.patch"
+
+ cd "${S}"
+ # in svn but missing from the release
+ cp "${FILESDIR}/antlib.xml" src/net/sf/antcontrib/cpptasks/antlib.xml || die
+ rm -v *.jar || die
+ java-ant_rewrite-classpath
+}
+
+EANT_BUILD_TARGET="jars"
+EANT_DOC_TARGET="javadocs -Dbuild.javadocs=build/api"
+EANT_GENTOO_CLASSPATH="ant-core,xerces-2"
+
+#The actual files for testing are not part of the release
+#src_test() {
+# eant run-tests
+#}
+
+src_install() {
+ java-pkg_dojar build/lib/${PN}.jar
+
+ java-pkg_register-ant-task
+
+ dodoc NOTICE || die
+ use doc && java-pkg_dojavadoc build/api
+ use examples && dodoc samples/*
+ use source && java-pkg_dosrc src/net
+
+}
diff --git a/dev-java/cpptasks/cpptasks-1.0_beta5.ebuild b/dev-java/cpptasks/cpptasks-1.0_beta5.ebuild
new file mode 100644
index 000000000000..fc0d20719617
--- /dev/null
+++ b/dev-java/cpptasks/cpptasks-1.0_beta5.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+JAVA_PKG_IUSE="doc source examples"
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Ant-tasks to compile various source languages and produce executables, shared and static libraries"
+HOMEPAGE="http://ant-contrib.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ant-contrib/ant-contrib/${P/_/-}/${P/_beta/b}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+COMMON_DEP="
+ dev-java/ant-core:0
+ dev-java/xerces:2"
+RDEPEND="${COMMON_DEP}
+ >=virtual/jre-1.4"
+DEPEND="${COMMON_DEP}
+ >=virtual/jdk-1.4"
+
+S="${WORKDIR}/${P/_beta/b}"
+
+java_prepare() {
+ find -name '*.jar' -exec rm -v {} + || die
+
+# Doesn't apply any longer.
+# # https://sourceforge.net/tracker/index.php?func=detail&aid=829906&group_id=36177&atid=416920
+# # https://bugs.gentoo.org/show_bug.cgi?id=156596
+# epatch "${FILESDIR}/1.0b4-profiling.patch"
+}
+
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+
+EANT_BUILD_TARGET="jars"
+EANT_DOC_TARGET="javadocs -Dbuild.javadocs=build/api"
+EANT_GENTOO_CLASSPATH="ant-core,xerces-2"
+
+# TODO
+#src_test() {
+# eant run-tests
+#}
+
+src_install() {
+ java-pkg_dojar target/lib/${PN}.jar
+
+ java-pkg_register-ant-task
+
+ dodoc NOTICE
+ use doc && java-pkg_dojavadoc build/api
+ use examples && java-pkg_doexamples src/samples/*
+ use source && java-pkg_dosrc src/main/java/*
+}
diff --git a/dev-java/cpptasks/files/1.0b4-profiling.patch b/dev-java/cpptasks/files/1.0b4-profiling.patch
new file mode 100644
index 000000000000..6795ecd59fcd
--- /dev/null
+++ b/dev-java/cpptasks/files/1.0b4-profiling.patch
@@ -0,0 +1,27 @@
+https://bugs.gentoo.org/attachment.cgi?id=102974
+https://sourceforge.net/tracker/index.php?func=detail&aid=829906&group_id=36177&atid=416920
+
+diff -ur cpptasks-1.0b4.orig/src/net/sf/antcontrib/cpptasks/gcc/GccLinker.java cpptasks-1.0b4/src/net/sf/antcontrib/cpptasks/gcc/GccLinker.java
+--- cpptasks-1.0b4.orig/src/net/sf/antcontrib/cpptasks/gcc/GccLinker.java 2006-11-29 13:05:30.000000000 +0100
++++ cpptasks-1.0b4/src/net/sf/antcontrib/cpptasks/gcc/GccLinker.java 2006-11-29 13:14:00.000000000 +0100
+@@ -35,7 +35,7 @@
+ private static String[] linkerOptions = new String[]{"-bundle",
+ "-dynamiclib", "-nostartfiles", "-nostdlib", "-prebind", "-s",
+ "-static", "-shared", "-symbolic", "-Xlinker",
+- "--export-all-symbols", "-static-libgcc",};
++ "--export-all-symbols", "-static-libgcc", "-pg", };
+ private static final GccLinker dllLinker = new GccLinker("gcc", objFiles,
+ discardFiles, "lib", ".so", false, new GccLinker("gcc", objFiles,
+ discardFiles, "lib", ".so", true, null));
+diff -ur cpptasks-1.0b4.orig/src/net/sf/antcontrib/cpptasks/gcc/GppLinker.java cpptasks-1.0b4/src/net/sf/antcontrib/cpptasks/gcc/GppLinker.java
+--- cpptasks-1.0b4.orig/src/net/sf/antcontrib/cpptasks/gcc/GppLinker.java 2006-11-29 13:05:30.000000000 +0100
++++ cpptasks-1.0b4/src/net/sf/antcontrib/cpptasks/gcc/GppLinker.java 2006-11-29 13:13:21.000000000 +0100
+@@ -41,7 +41,7 @@
+ ".lib", ".dll", ".so", ".sl"};
+ private static String[] linkerOptions = new String[]{"-bundle", "-dylib",
+ "-dynamic", "-dynamiclib", "-nostartfiles", "-nostdlib",
+- "-prebind", "-s", "-static", "-shared", "-symbolic", "-Xlinker"};
++ "-prebind", "-s", "-static", "-shared", "-symbolic", "-Xlinker", "-pg" };
+ private static final GppLinker instance = new GppLinker("gcc", objFiles,
+ discardFiles, "", "", false, null);
+ private static final GppLinker machDllLinker = new GppLinker("gcc",
diff --git a/dev-java/cpptasks/files/antlib.xml b/dev-java/cpptasks/files/antlib.xml
new file mode 100644
index 000000000000..5f8af42ad557
--- /dev/null
+++ b/dev-java/cpptasks/files/antlib.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0"?>
+ <!--
+ *
+ * Copyright 2004 The Ant-Contrib project
+ *
+ * Licensed under the Apache License, Version 2.0 (the "License");
+ * you may not use this file except in compliance with the License.
+ * You may obtain a copy of the License at
+ *
+ * http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing, software
+ * distributed under the License is distributed on an "AS IS" BASIS,
+ * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ * See the License for the specific language governing permissions and
+ * limitations under the License.
+ -->
+ <antlib>
+ <taskdef resource="cpptasks.tasks" />
+ <typedef resource="cpptasks.types" />
+ </antlib>
+ \ No newline at end of file
diff --git a/dev-java/cpptasks/metadata.xml b/dev-java/cpptasks/metadata.xml
new file mode 100644
index 000000000000..9452de6d1452
--- /dev/null
+++ b/dev-java/cpptasks/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <upstream>
+ <remote-id type="sourceforge">ant-contrib</remote-id>
+ </upstream>
+</pkgmetadata>