summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-01-20 23:59:44 +0100
committerPatrice Clement <monsieurp@gentoo.org>2018-01-21 00:01:43 +0100
commit7c1cdfa56144aeb5c321840de1954cd2ce92e3bd (patch)
tree77119a5455cdd862eb456358e9fa6e76bcd15731 /dev-java/cssparser/cssparser-0.9.24.ebuild
parentx11-misc/lightdm: Drop 1.18.3 (r0) (diff)
downloadgentoo-7c1cdfa56144aeb5c321840de1954cd2ce92e3bd.tar.gz
gentoo-7c1cdfa56144aeb5c321840de1954cd2ce92e3bd.tar.bz2
gentoo-7c1cdfa56144aeb5c321840de1954cd2ce92e3bd.zip
dev-java/cssparser: version bump.
Diffstat (limited to 'dev-java/cssparser/cssparser-0.9.24.ebuild')
-rw-r--r--dev-java/cssparser/cssparser-0.9.24.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-java/cssparser/cssparser-0.9.24.ebuild b/dev-java/cssparser/cssparser-0.9.24.ebuild
new file mode 100644
index 000000000000..4e2aa29ee99f
--- /dev/null
+++ b/dev-java/cssparser/cssparser-0.9.24.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="API for parsing CSS 2 in Java"
+HOMEPAGE="http://cssparser.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-sources.jar -> ${P}.jar"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND="dev-java/sac:0"
+
+DEPEND="
+ ${CDEPEND}
+ >=virtual/jdk-1.6"
+
+RDEPEND="
+ ${CDEPEND}
+ >=virtual/jre-1.6"
+
+JAVA_GENTOO_CLASSPATH="sac"