summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/eclipsito
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/eclipsito')
-rw-r--r--dev-java/eclipsito/Manifest1
-rw-r--r--dev-java/eclipsito/eclipsito-0_pre20130713.ebuild33
-rw-r--r--dev-java/eclipsito/files/eclipsito-0_pre20130713-build.xml36
-rw-r--r--dev-java/eclipsito/metadata.xml5
4 files changed, 75 insertions, 0 deletions
diff --git a/dev-java/eclipsito/Manifest b/dev-java/eclipsito/Manifest
new file mode 100644
index 000000000000..ae8c8fdc309b
--- /dev/null
+++ b/dev-java/eclipsito/Manifest
@@ -0,0 +1 @@
+DIST eclipsito-0_pre20130713.tar.xz 162972 SHA256 2ac637b26a30263777d2c92912e0607a26d379f14a9c1a4a3cd28a9960b15c10 SHA512 b238692950bc93059fb16df8e6301669583185976ae4f12519d1917a13fea2b53c5b3462f2da61d63025019eee10037a3a96b2ac742545d61b80f2ab7964d41b WHIRLPOOL b2dbecf2d0c80f851d0c4253c6aa8b9657e5f39802a30d5385231c985c406702ebeca92645969c8bbf6cf11fb3ebb2fa77b755a46a3e99fd26f45b40efedee48
diff --git a/dev-java/eclipsito/eclipsito-0_pre20130713.ebuild b/dev-java/eclipsito/eclipsito-0_pre20130713.ebuild
new file mode 100644
index 000000000000..4488566d6ca4
--- /dev/null
+++ b/dev-java/eclipsito/eclipsito-0_pre20130713.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="A small subset of Eclipse core libraries for modular applications"
+HOMEPAGE="https://code.google.com/p/eclipsito/"
+SRC_URI="http://dev.gentoo.org/~tomwij/files/dist/${P}.tar.xz"
+
+LICENSE="EPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=virtual/jre-1.5"
+DEPEND=">=virtual/jdk-1.5"
+
+S="${WORKDIR}/${PN}/org.bardsoftware.${PN}"
+
+java_prepare() {
+ epatch "${FILESDIR}"/${P}-build.xml
+}
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+
+ use doc && java-pkg_dojavadoc apidocs
+ use source && java-pkg_dosrc src/
+}
diff --git a/dev-java/eclipsito/files/eclipsito-0_pre20130713-build.xml b/dev-java/eclipsito/files/eclipsito-0_pre20130713-build.xml
new file mode 100644
index 000000000000..c6055e5525c3
--- /dev/null
+++ b/dev-java/eclipsito/files/eclipsito-0_pre20130713-build.xml
@@ -0,0 +1,36 @@
+diff --git a/build.xml b/build.xml
+index d89485a..7be5431 100644
+--- a/build.xml
++++ b/build.xml
+@@ -17,4 +17,31 @@
+ <target depends="build" name="jar">
+ <jar destfile="eclipsito.jar" basedir="bin" compress="yes"/>
+ </target>
++
++ <target name="javadoc" description="Generates the Javadoc of the application">
++ <javadoc sourcepath="src"
++ packagenames="*"
++ destdir="apidocs"
++ access="protected"
++ old="false"
++ verbose="false"
++ encoding="UTF-8"
++ version="true"
++ use="true"
++ author="true"
++ splitindex="false"
++ nodeprecated="false"
++ nodeprecatedlist="false"
++ notree="false"
++ noindex="false"
++ nohelp="false"
++ nonavbar="false"
++ serialwarn="false"
++ charset="ISO-8859-1"
++ docencoding="UTF-8"
++ source="1.5"
++ linksource="true"
++ breakiterator="false">
++ </javadoc>
++ </target>
+ </project>
diff --git a/dev-java/eclipsito/metadata.xml b/dev-java/eclipsito/metadata.xml
new file mode 100644
index 000000000000..838c00a4a448
--- /dev/null
+++ b/dev-java/eclipsito/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+</pkgmetadata>